Dimmer association and physical inputs are not being registered

Hey all, I did my best to search but I keep coming up empty.

I recently installed openHAB 2 and I’m trying to get going with my zwave dimmer switch. I’ve created a sitemap file (and the corresponding items file) with two items (one for the switch, and one for the dimmer). I can send commands to the dimmer from this sitemap file, and it works fine.

I have two problems which I’m thinking are the same root issue. If I make any changes on the physical switch, be that changing the brightness, or turning the light on/off, it is not reflected in openHAB. Similarly, If I were to refresh the webpage for openHAB, the switch appears off, even if the physical switch is on.

I have a Cooper Wiring Devices RF9540-N which I specifically bought because it supported associations. In HABmin, under association groups for this device it has “openHAB Controller” listed.

I have also tailed the events.log file and I see nothing logged when inputs are made to the physical switch. To my understanding, I have everything set as it should be, but I’m getting no love from this thing.

I know openHAB 2 is still rapidly moving, but I feel like this is pretty basic functionality, so I feel like I must be missing something.

It’s probably a device configuration issue, but I would suggest looking in the debug logs to see if the device is sending anything when the button is pressed.

@chris thanks for the quick reply.

I’ve been plugging away after my first post, and by tailing the openhab.log, I see that the device reports events when the dimmer switch is adjusted, but not the on/off toggle, it seems.

In the paper UI, I removed the device and re-detected it, and I noticed that it comes up as an “Unknown Device”, but the description of it shows as “Z-Wave Node 3: RF9540-N All Load Dimmer Light Switch”. Could the fact that it’s unknown be the cause for this?

It’s unlikely - the device will either report or not - the database shouldn’t impact on what the device is reporting.

For log viewing you can also use the viewer on the web - www.cd-jackson.com. It might be easier to see what’s happening…


Unfortunately I don’t see anything helpful in the logs (although I don’t think I’m seeing actual debug info). As I said, I do see brightness events when using the dimmer, but I don’t see any events for on/off.

This strikes me as odd, because I would assume the on/off functionality is the more basic of the two. I’m stumped.

Is it possible the USB controller isn’t interpreting the command(s) correctly? I have a zwave.me UZB1, if that matters.

Thanks for your help so far.

I very much doubt the stick isn’t interpreting the commands correctly - it’s more likely that the device doesn’t send the information if it’s not in the debug log. That said, it would be surprising if it’s not sending this data but if you’re seeing the summer data then clearly the associations must be configured ok.

Why don’t you think you’re seeing debug logging? It should be obvious as it will say DEBUG on the beginning of the line. If you want you can email me the log and I’ll take a look.

Hey @chris,

I don’t think I’m seeing debug logging because I’m not seeing any lines prefixed with “DEBUG”. All I’m seeing are entries like “INFO” and “ERROR” for the most part. Normally I run openHAB2 as a service, but I ran the start_debug.sh script and I get the same thing.

The events I do see from the dimmer being adjusted show up as INFO events. I’m happy to share the log, but without debug entries, I doubt it’s of any use to you.

Thanks again for your help, I really appreciate it.

You need to enable debug logging - it doesn’t matter what start script you use, the default log level will be INFO.

To enable debug logging, use the console command log:set debug org.openhab.binding.zwave.


Hey @chris,

Thanks for the help. I sent you a message with a link to my openhab.log with debugging enabled. Looking forward to your thoughts.


The general sequence of events in the log was me turning the light on, dimming, and then off from openHAB. This is followed by me repeating the process (more or less) from the physical switch.

I suspect the issue is that the device is using different classes for dim and on/off. I’ve updated the database and will try and update the binding with this tonight. Hopefully it will solve the problem, but let’s see :slight_smile:


That sounds awesome. I’m unfamiliar with this process though. Would I need to remove the binding and re-add it, or is there some sort of update mechanism?

Thanks again. Looking forward to testing out the changes.

To upgrade to the latest binding, and assuming you’re using the online version, simply uninstall the binding (in the extensions menu) and then install it again.

That was easy enough. Unfortunately (unless the uninstall/install didn’t work), I’m seeing the same behavior.

With debug logging turned on, I see the “NODE 3: Incoming command class BASIC” entries when turning the switch off and on from the physical switch, but without the debug, I don’t see that event.

Is there a way to verify that I have the correct version of the zwave extension? Thanks again.

From the console, type the list | grep ZWave command. This will show the version of the binding you’re running.

197 | Active   |  80 | 2.0.0.b3              | ZWave Binding

So that’s still the old version. Are you using the online version, or offline?

I was using the offline, not for any particular reason other than having no idea what I was doing. I removed that package, and installed the online package based on your previous comment.

I’m going to guess that there are bits that get left over from the package removal. It seems the “things” database that oh2 creates was still there as well. I’ll try removing and installing again. I’m not sure where that database lives, however.

You don’t need to delete the database, but, you do need to delete the thing.

In HABmin (or PaperUI I guess), just delete the thing, and then click on the discovery button and add it back in. This will cause it to pick up the latest database definition.

Ok, I blew away the installation and removed any openhab2 directories that I could find. I think I figured out where the db is too, and deleted that.

I don’t have much time or effort into configuring it, so I don’t mind. Plus it’s a decent learning experience. After going through this, I didn’t have any existing extensions or things showing up, so I added zwave, and the controller.

It immediately found the dimmer node, but there is a TON of chatter between the node and controller. It seems like it’s in some sort of loop.

I versioned the zwave extension again, and it says “2.0.0.b3” which you said wasn’t updated. I’m not sure if I’m doing something wrong. Let me know if you’d like to see the log again, or if there’s anything else I can do to streamline your helping me troubleshoot here.

Thanks again.

Edit: I re-read my post and realized the “chatter” comment sounds like something’s wrong, and I don’t know that to be the case. It’s just different. I assume this is related to the “thing” file being changed. I’d also assume that I need that updated extension in order for any of your changes to have an effect. But, I look forward to your thoughts.

When you updated the system, did you grab the latest version from cloudbees?


If you downloaded the beta 3 version, then even the online version might be configured only to download the beta 3 bindings.