Dimmers in HomeKit cause RGBWW Bulbs to flicker

I am having a weird issue with my Tasmota RGBWW bulbs that flicker when the dimmers are being adjusted in HomeKit. It looks like they briefly switch to 100% while raising or lowering the value on a slider.

I am not sure if this is a HomeKit, openHAB, or Tasmota issue. I don’t see the flashing when using sliders in OH2 (Sitemaps and PaperUI->Control), but they are not a live adjust like in HomeKit (the bulb does not change until you let go of the slider).

Has anyone else run into this problem and have a solution?

Here is a sample of my configuration…


Bridge mqtt:broker:myBroker [ host="192.168.xxx.xxx", secure=false, username="user", password="pass" ] {
  Thing mqtt:topic:diningRoomLight  "Dining Room Light"
  { Channels:
    Type switch     : diningRoomLightPower      "Light"             [ stateTopic="stat/diningRoomLight/POWER", commandTopic="cmnd/diningRoomLight/POWER" ]
    Type dimmer     : diningRoomLightBrightness "Brightness"        [ stateTopic="stat/diningRoomLight/DIMMER", commandTopic="cmnd/diningRoomLight/DIMMER" ]
    Type dimmer     : diningRoomLightWarmth     "Warmth"            [ stateTopic="stat/diningRoomLight/CT", commandTopic="cmnd/diningRoomLight/CT", min=153, max=500, step=10  ]
    Type colorHSB   : diningRoomLightColor      "Color"             [ stateTopic="stat/diningRoomLight/HSBColor", commandTopic="cmnd/diningRoomLight/HSBColor" ]


Switch  diningRoomLightPower        "Light"             ["Lighting"]        { channel="mqtt:topic:diningRoomLight:diningRoomLightPower" }
Dimmer  diningRoomLightBrightness   "Brightness"        ["Lighting"]        { channel="mqtt:topic:diningRoomLight:diningRoomLightBrightness" }
Dimmer  diningRoomLightWarmth       "Warmth"            ["Lighting"]        { channel="mqtt:topic:diningRoomLight:diningRoomLightWarmth" }
Color   diningRoomLightColor        "Color"             ["Lighting"]        { channel="mqtt:topic:diningRoomLight:diningRoomLightColor" }


sitemap lightTest label="Lighting Slider Test" {
Frame label="Dining Room Light" {
    Switch          item=diningRoomLightPower       label="Power"       icon="switch"
    Slider          item=diningRoomLightBrightness  label="Brightness"  icon="slider"       sendFrequency=0     minValue=1      maxValue=100    step=1
    Slider          item=diningRoomLightWarmth      label="Warmth"      icon="slider"       sendFrequency=0     minValue=1      maxValue=100    step=1
    Colorpicker     item=diningRoomLightColor       label="Color"       icon="colorpicker"  sendFrequency=0


Sorry but did you find a solution ?

I never did. If memory serves, I moved the bulbs to Homebridge.

However, I recently solved a different flickering problem by setting a fade value for the bulb in the tasmota console. Anything other than 0 (or no fade) would probably reduce the problem.