Dimmers not working with KNX 2.0 binding

Tags: #<Tag:0x00007fc20a721ec8>

Hello gents,

I’ve switched from OH 2.2.0 to OH 2.3.0 and I tought it might be a good time to migrate to the new KNX 2.0 binding.

Things went a little worse than I expected and took a lot more time, let’s say, and I mean this as a warning to everybody switching from KNX 1.0 binding to 2.0, I spent a good part of the weekend completely rewriting my KNX configuration for the new hybrid Things / items configuration.

But that’s ok, I guess it had to happen at some time.

Now, my problem, all my dimmers were previously working in the KNX 1.0 binding but now none of them is working anymore.

After setting TRACE in the logs with “log:set trace org.openhab.binding.knx” I found this error:

21:05:28.581 [INFO ] [smarthome.event.ItemCommandEvent ] - Item ‘Luce_Camera_Matrimoniale_Dimmer’ received command 7
21:05:28.584 [TRACE] [x.internal.handler.DeviceThingHandler] - Handling command ‘7’ for channel ‘knx:device:bridge:act_dim_1:Luce_Camera_Matrimoniale_Dimmer’
21:05:28.598 [INFO ] [smarthome.event.ItemStateChangedEvent] - Luce_Camera_Matrimoniale_Dimmer changed from 0 to 7
21:05:28.602 [DEBUG] [x.internal.handler.DeviceThingHandler] - None of the configured GAs on channel ‘knx:device:bridge:act_dim_1:Luce_Camera_Matrimoniale_Dimmer’ could handle the command ‘7’ of type ‘PercentType’

That seems very strange to me as I think my dimmers are kinda standard, here’s some example GAs for my KNX configuration:

SET on/off - 2/0/17 dpt 1.001
GET state on off - 2/1/17 dpt 1.001
dimming command - 2/2/17 dpt 3.007
SET absolute dimming value - 2/3/17 dpt 5.001
GET absolute dimming value - 2/4/17 dpt 5.001

Therefor in my knx.things I have:

Type dimmer : Luce_Camera_Matrimoniale_Dimmer "Dimmer camera matrimoniale [%s %%]" [ switch="2/0/17+<2/1/17", position="5.001:2/3/17+<5.001:2/4/17", increaseDecrease="3.007:2/2/17" ]

and in my knx.items:

Dimmer Luce_Camera_Matrimoniale_Dimmer "Dimmer camera matrimoniale [%s %%]" <dimmablelight> (LIGHT) { channel="knx:device:bridge:act_dim_1:Luce_Camera_Matrimoniale_Dimmer" }

Any clues on what I might be actually doing wrong? I’m confused…

Many thanks!

Simone.

(not sure if this will help… anyway DPT 5:001 is the default for position GAs)
instead of:

position="5.001:2/3/17+<5.001:2/4/17"

try:

position="5.001:2/3/17+5.001:<2/4/17"

Also, since you define the name and the Label of the Item in the knx.items, you should give the channel Luce_Camera_Matrimoniale_Dimmer another name and label

e.g

Type dimmer : Dim_Channel_1 "Dimmer Channel 1" [ switch="2/0/17+<2/1/17", position="5.001:2/3/17+5.001:<2/4/17", increaseDecrease="3.007:2/2/17" ]
1 Like

Same issue here. I have not checked the log file in trace mode. But all dimmer channels are not working anymore. The status of the actuator are readable but no reaction while dimming via openhab…
here is my config:

		Thing device DM-4-2_EG "DM-4-2 T EG" @ "KNX" /*[
			address="1.1.20", 
		   	fetch=false, 
		   	pingInterval=600, 
		   	readInterval=0 
		   ]*/
		{
			Type switch  : ShortCircuit_Ch1      "Channel 1 Short Circuit"          [ ga="<8/3/12" ]
			Type switch  : GeneralError_Ch1      "Channel 1 General Error"          [ ga="<8/3/16" ]
			Type switch  : SupplyError_Ch1       "Channel 1 Supply Error"           [ ga="<8/3/20" ]
			Type switch  : ShortCircuit_Ch2      "Channel 2 Short Circuit"          [ ga="<8/3/13" ]
			Type switch  : GeneralError_Ch2      "Channel 2 General Error"          [ ga="<8/3/17" ]
			Type switch  : SupplyError_Ch2       "Channel 2 Supply Error"           [ ga="<8/3/21" ]
			Type switch  : ShortCircuit_Ch3      "Channel 3 Short Circuit"          [ ga="<8/3/14" ]
			Type switch  : GeneralError_Ch3      "Channel 3 General Error"          [ ga="<8/3/18" ]
			Type switch  : SupplyError_Ch3       "Channel 3 Supply Error"           [ ga="<8/3/22" ]
			Type switch  : ShortCircuit_Ch4      "Channel 4 Short Circuit"          [ ga="<8/3/15" ]
			Type switch  : GeneralError_Ch4      "Channel 4 General Error"          [ ga="<8/3/19" ]
			Type switch  : SupplyError_Ch4       "Channel 4 Supply Error"           [ ga="<8/3/23" ]

			Type dimmer  : Channel_1       "Channel 1"            [ switch="1/1/10 + <1/4/10", position="5.001:1/3/10 + 5.001:<1/6/10", increaseDecrease="3.007:1/2/10" ]
			Type dimmer  : Channel_2       "Channel 2"            [ switch="1/1/16 + <1/4/16", position="5.001:1/3/16 + 5.001:<1/6/16", increaseDecrease="3.007:1/2/16" ]
			Type dimmer  : Channel_3       "Channel 3"            [ switch="1/1/0 + <1/4/0",   position="5.001:1/3/0 + 5.001:<1/6/0",   increaseDecrease="3.007:1/2/0" ]
			Type dimmer  : Channel_4       "Channel 4"            [ switch="1/1/40 + <1/4/40", position="5.001:1/3/40 + 5.001:<1/6/40", increaseDecrease="3.007:1/2/40" ]

		}
Dimmer Dm_EG_Kueche_Thresen       "Küche Thresen [%d %%]"        (gLicht, gKueche)                 [ "Lighting" ]    { channel="knx:device:MdtScnIp100_02:DM-4-2_EG:Channel_1" }
Dimmer Dm_EG_Essen_Deckenlicht    "Essen Deckenlicht [%d %%]"    (gLicht, gEsszimmer)              [ "Lighting" ]    { channel="knx:device:MdtScnIp100_02:DM-4-2_EG:Channel_2" }
Dimmer Dm_EG_Wohnen_Deckenlicht   "Wohnen Deckenlicht [%d %%]"   (gLicht, gWohnzimmer)             [ "Lighting" ]    { channel="knx:device:MdtScnIp100_02:DM-4-2_EG:Channel_3" }
Dimmer Dm_EG_Flur_Deckenlicht     "Flur EG Deckenlicht [%d %%]"  (gLicht, gGroundFloor, gFlurEG)   [ "Lighting" ]    { channel="knx:device:MdtScnIp100_02:DM-4-2_EG:Channel_4" }

Hello Dim and thanks for the reply,

I’ve been a little quick in exposing my configuration so here’s some additional data.

Having rewritten everything since going the route of KNX 2.0 binding my config now has:

knx.things:

...
Thing device act_dim_1 [
        address="1.1.5",
        fetch=true,
        pingInterval=300,
        readInterval=3600
    ] {      
        Type dimmer        : Luce_Camera_Matrimoniale_Dimmer    "Dimmer camera matrimoniale [%s %%]"    [ switch="2/0/17+<2/1/17", position="5.001:2/3/17+5.001:<2/4/17", increaseDecrease="3.007:2/2/17" ]
    }
...

knx.items:

...
//act 1.1.5
Dimmer        Luce_Camera_Matrimoniale_Dimmer   "Dimmer camera matrimoniale [%s %%]" <dimmablelight> (LIGHT) { channel="knx:device:bridge:act_dim_1:Luce_Camera_Matrimoniale_Dimmer" }

...

And as you can see I made the change from:

5.001:2/3/17+<5.001:2/4/17
to:
5.001:2/3/17+5.001:<2/4/17

But still, it’s not working!

What else might I be doing wrong?

Many thanks!

Simone.

Hello Adrian,

I see that we have the same problem with dimmers using the new KNX 2.0 binding.

May I ask what actuator you’re using in your KINX setup?

Mine is from Ekinex, model EK-GA1-TP, and here’s a link to the product sheet:

I hope we can find a way to make it work.

Thank you,

Simone.

Just in case:
How are you sending the command?
Using a sitemap on BasicUI and a Slider element? (or a rule?)
Post that sitemap entry plz to check it

Also: double/triple check your GA assignments… you never know :slight_smile:

Hi Simone,
I am using a Theben DM4-2.

So I checked my log file in trace mode and it seems to be the same behaviour.

2018-06-10 21:42:07.694 [TRACE] [.internal.handler.DeviceThingHandler] - Handling command '38' for channel 'knx:device:MdtScnIp100_02:DM-4-2_EG:Channel_2'
2018-06-10 21:42:07.695 [DEBUG] [.internal.handler.DeviceThingHandler] - None of the configured GAs on channel 'knx:device:MdtScnIp100_02:DM-4-2_EG:Channel_2' could handle the command '38' of type 'PercentType'

Best Regards
Adrian

Hi Adrian,

I am facing a similar issue with KNX2 using numbers (see https://community.openhab.org/t/knx2-none-of-the-configured-gas-on-channel-could-handle-the-command/46196/2). In my scenario the listening GA is causing the issue.

If I create a new thing (changing the existing one doesn’t work due to another possible KNX2 bug) having a channel without listening GAs the telegrams are written to the GA.

Can you please try that? Maybe those issues are related. I got no response to my thread yet - this one seems to be more active.

BR
Rene

Hi Adrian,

I found the solution to my problem in another thread. If you use the DPT only once in front of both GAs it is working.

Not working:

5.001:2/3/17+<5.001:2/4/17

Working:

5.001:2/3/17+<2/4/17

Can you please check if it solves your problem as well?

Please don’t forget to use a different thing for the test as changing a channel configuration is not reflected at runtime - at least not for me. With a new thing it worked.

BR
Rene

1 Like

Hi Rene,
thank you very much for your suggestion! After an other issue it is working now.
It seems to be important as well to have no blanks between the GAs and the +.
So this is working:

"5.001:1/3/55+<1/6/55"

while this is not working:

"5.001:1/3/55 + <1/6/55"
1 Like

Hi again Dim,

I’m testing this via Habpanel, which is my main interface to OpenHAB and has always worked consistently so far, therefore I’m not really updating my sitemap anymore…)

I made some changes doing what Rene suggested, right now I cannot test anything but tonight I’ll try again and post an update here.

I plan to entirely restart the OpenHAB container (I’m running on Docker) so to avoid the other possible bug Rene mentioned about “things” not updating at runtime.

Now that I think of it this single issue could be a real mess when testing and doing config changes…

Many thanks!

Simone.

p.s.: I’m also checking the GAs one more time, you never know :wink:

1 Like

Hi,

same behaviour in my environment for dimmers. When I configure the thing like this:

Type dimmer-control : logicdimmerEGKuecheSpots “EG Küche Spots” [position="<5.001:0/1/104"]

…it is throws following debug message:
2018-06-12 22:08:09.673 [TRACE] [.internal.handler.DeviceThingHandler] - Handling command ‘25’ for channel ‘knx:device:bridge:LichtsteuerungOpenhab:logicdimmerEGKuecheSpots’
2018-06-12 22:08:09.673 [DEBUG] [.internal.handler.DeviceThingHandler] - None of the configured GAs on channel ‘knx:device:bridge:LichtsteuerungOpenhab:logicdimmerEGKuecheSpots’ could handle the command ‘25’ of type ‘PercentType’

Setting it up the following way:

Type dimmer-control : logicdimmerEGKuecheSpots “EG Küche Spots” [position=“5.001:0/1/104”]

…it works and is giving following messages:

2018-06-12 22:33:37.863 [TRACE] [.internal.handler.DeviceThingHandler] - Handling command ‘25’ for channel ‘knx:device:bridge:LichtsteuerungOpenhab:logicdimmerEGKuecheSpots’
2018-06-12 22:33:37.863 [DEBUG] [nx.internal.client.AbstractKNXClient] - Wrote value ‘25’ to datapoint ‘command DP 0/1/104 ‘knx:ip:bridge’, DPT id 5.001, low priority’ (0. attempt).

Hi Rene,

thanks again! My dimmers are now working with the syntax you suggested.

But, apart from the syntax (I guess this could be clarified in the official KNX 2.0 binding docs) I believe the biggest issue causing confusion is the one where changing thins won’t update anything at runtime and you have to relaunch OpenHAB.

I’m glad we found a solution, please point others you know who face the same issue to this thread.

Simone.

1 Like

Hi Rene,

from my site also thanks a lot. This article helps me to configure my KNX dimmers and now it works perfect!

Hi,

Could somebody point me into right direction?
I recently moved from knx1 to knx2 after many days of nice reconfiguration(quite painful as I have most of the stuff in knx) and eventually almost everything seems to be working fine except dimmers.
It looks configured correctly, but I cannot use it and get only the following in the logfile:

25-Aug-2019 11:48:09.240 [DEBUG] [ab.binding.knx.internal.handler.DeviceThingHandler] - None of the configured GAs on channel 'knx:device:MDTRouter:MDT_AKD:Channel_D' could handle the command '100' of type 'PercentType'

Things:

    Thing device MDT_AKD "Dimming Actuator - 4 fold" @ "KNX" [ fetch=false, pingInterval=600, readInterval=0 ]
        {
            Type    dimmer  :       Channel_D      "Swiatlo_Parter_Salon_Sufit2"                [ switch="1/1/30+1/4/29", position="1/1/32+1/1/33", increaseDecrease="1/1/31" ]
    }

items:

Dimmer           Swiatlo_Parter_Salon_Sufit2              "Salon Sufit2"                                        (Parter_Salon, Oswietlenie, Oswietlenie_Parter,Parter_Sciemniacze)          { channel="knx:device:MDTRouter:MDT_AKD:Channel_D" }

On knx1 this configuration worked perfectly fine.

Hi,

could somebody please have a look at my configuration?
My dimmer doesn´t work with Openhab 2.5 and KNX 2.0.
I tried many tips from this and other topics, but I don´t see my mistake.

ETS Configuration:

knx.things

Thing device Dimmer1 [
            address="1.1.48",
            fetch=true,
            pingInterval=300,
            readInterval=3600
        ] {
Type dimmer : cLicht_StrahlerTerrasse       " Strahler Dim Terrasse [%d %%]"     [ switch="1.001:7/0/10+<7/0/11", position="5.001:7/0/21+<7/0/22", increaseDecrease="3.007:7/0/20"  ]
        }

knx.items

Dimmer Licht_StrahlerTerrasse       " Strahler Dim Terrasse [%d %%]" <terrace>  (A_Aussen)   ["Lighting"] {channel="knx:device:bridge:Lichter1:cLicht_StrahlerTerrasse", autoupdate="false"}

I get status updates on a regular base, as defined in ETS:

2020-02-12 20:17:29.396 [DEBUG] [.internal.handler.DeviceThingHandler] - onGroupWrite Thing ‘knx:device:bridge:Dimmer1’ received a GroupValueWrite telegram from ‘1.1.48’ for destination ‘7/0/11’

When I tried to use the dimmer in OpenHab Classic UI:

2020-02-12 19:53:08.876 [ome.event.ItemCommandEvent] - Item ‘Licht_StrahlerTerrasse’ received command 51
2020-02-12 19:53:08.883 [nt.ItemStatePredictedEvent] - Licht_StrahlerTerrasse predicted to become

When I use my wall-switch (1.1.17) to soft-switch the dimmer:

2020-02-12 20:43:17.292 [DEBUG] [.internal.handler.DeviceThingHandler] - onGroupWrite Thing ‘knx:device:bridge:Dimmer1’ received a GroupValueWrite telegram from ‘1.1.17’ for destination ‘7/0/10’
2020-02-12 20:43:17.653 [DEBUG] [.internal.handler.DeviceThingHandler] - onGroupWrite Thing ‘knx:device:bridge:Dimmer1’ received a GroupValueWrite telegram from ‘1.1.48’ for destination ‘7/0/11’
2020-02-12 20:43:21.405 [DEBUG] [.internal.handler.DeviceThingHandler] - onGroupWrite Thing ‘knx:device:bridge:Dimmer1’ received a GroupValueWrite telegram from ‘1.1.48’ for destination ‘7/0/22’

When I tried to use the dimmer in OpenHab Classic UI (autoupdate=“false” => so there is no “predicted” anymore):

2020-02-12 20:48:14.828 [ome.event.ItemCommandEvent] - Item ‘Licht_StrahlerTerrasse’ received command 100
2020-02-12 20:48:16.957 [ome.event.ItemCommandEvent] - Item ‘Licht_StrahlerTerrasse’ received command 0
2020-02-12 20:48:23.743 [ome.event.ItemCommandEvent] - Item ‘Licht_StrahlerTerrasse’ received command 54

When I tried to use the dimmer on my wall-switch the light works as it should and I get the following log entries:

==> /var/log/openhab2/openhab.log <==
2020-02-12 20:48:32.901 [DEBUG] [.internal.handler.DeviceThingHandler] - onGroupWrite Thing ‘knx:device:bridge:Dimmer1’ received a GroupValueWrite telegram from ‘1.1.17’ for destination ‘7/0/20’

2020-02-12 20:48:33.916 [DEBUG] [.internal.handler.DeviceThingHandler] - onGroupWrite Thing ‘knx:device:bridge:Dimmer1’ received a GroupValueWrite telegram from ‘1.1.17’ for destination ‘7/0/20’

2020-02-12 20:48:34.425 [DEBUG] [.internal.handler.DeviceThingHandler] - onGroupWrite Thing ‘knx:device:bridge:Dimmer1’ received a GroupValueWrite telegram from ‘1.1.17’ for destination ‘7/0/20’

2020-02-12 20:48:34.934 [DEBUG] [.internal.handler.DeviceThingHandler] - onGroupWrite Thing ‘knx:device:bridge:Dimmer1’ received a GroupValueWrite telegram from ‘1.1.17’ for destination ‘7/0/20’

2020-02-12 20:48:35.442 [DEBUG] [.internal.handler.DeviceThingHandler] - onGroupWrite Thing ‘knx:device:bridge:Dimmer1’ received a GroupValueWrite telegram from ‘1.1.17’ for destination ‘7/0/20’

2020-02-12 20:48:35.950 [DEBUG] [.internal.handler.DeviceThingHandler] - onGroupWrite Thing ‘knx:device:bridge:Dimmer1’ received a GroupValueWrite telegram from ‘1.1.17’ for destination ‘7/0/20’

2020-02-12 20:48:36.050 [DEBUG] [.internal.handler.DeviceThingHandler] - onGroupWrite Thing ‘knx:device:bridge:Dimmer1’ received a GroupValueWrite telegram from ‘1.1.17’ for destination ‘7/0/20’

2020-02-12 20:48:36.055 [DEBUG] [g.knx.internal.dpt.KNXCoreTypeMapper] - toType: KNX DPT_Control_Dimming: break received.

Please just let me know, if you need additional information.

Best regards,
jbk