Direct association

Tags: #<Tag:0x00007f74550648b8>

Hi There,

I would like to set up direct association between ZW129 and ZW116 in order to do so I have checked Aeotec documentation and find below mentioned information:

ZW116:
Basic Set = 0x00, turn OFF output load.
Basic Set = 0xFF maps to Binary Switch Set = 0xFF,
Basic Set = 0x00 maps to Binary Switch Set = 0x00,
Basic Get/Report maps to Binary Switch Get/Report.

ZW129:
5. Special rule of each command
5.1 Basic Command Class
When the control button is pressed once, the WallMote will send Basic Set = 0x00/0xFF to the associated nodes in association group 2 or 4.

So i though that - let’s give it a try and disable rule which is responsible to turn on and off my lights in office lamp - and set association group in 2 (just for left button of dual wall-mote) to send Basic Set in toggle mode to my node id 20 which is zw116 responsible for mentioned lamp.
I’ve woke up my wall-mote after parameter change and wait a while (1day) to be sure that all nodes have been woke up and new parameters have been set up. Unfortunately nothing is going on - both nodes see each other as direct neighbors.

Can you help me - is there something wrong? Shall I set up something more than group association?

Thanks in advance

WallMote:


Group association happens totally outside the OH zwave binding. It happens between your 2 devices. Since both your devices are Aeotec, perhaps Aeotec support could be of assistance.

I have not a lot of experience with direct associations, but did you try the Multilevel association group? (put your device in group 3)

I’ve wrote to Aeotec support.

Group 3 - same thing - it dosen’t work.

Make sure you are changing zwave parameters via HABmin and not via PaperUI. Also make sure the pending mark disappears after editing (for that you need to wake your remote several times).

I always use habmin and always woke up after.

Still dosent work. I have got reply form Aeotec:
For WallMote Quad and any device that you want it to control, you’ll need to make sure of at least a few things:

*** If WallMote Quad is a secure device (paired as secure), then all other Z-Wave devices must be secure to communicate.**
*** If WallMote Quad is non-secure device, then all other devices it is controling directly must be non-secure to communicate.**

Group #2 is Basic SET, make sure that the switches that you are controlling have Basic SET mapped properly, or react to basic set controls.

​-

As for Multisensor 6, Group #1 is used as the lifeline as well as the group association to control other Z-Wave devices using Basic SET controls as well.

I think both devices for examle node 14 and 16 are non secure:
14:


16:

Or maybe “using security” in above screens dosen’t mean taht?

Using security means exactly that - it means the devices are not using using security - ie they are not securely included into the network.

Can you provide a debug log showing the setting of the associations?

Do you mean a debug log of OpenHab for certain period of time? If not please decribe in short steps how to reach it.

Or team viewer me :slight_smile:

Yes.

  • Enable debug logging
  • Set the associations
  • Wake the device up
  • Wake the device up again for good measure
  • Stop the debugging - or just post the log

Unfortunately I’m on holiday in Japan at the moment so arranging this isn’t the easiest as I’m travelling around. Let’s try the log and take it from there.

The process is documented under the heading of what to do when things do not go as planned.

1 Like

DEBUG is set - let me just finish OTA update for multisensor 6 and then I will provide log file according to your instruction - after wakeup and setup.

Thank you in advance and have a good time in Japan :slight_smile:
@Bruce_Osborne thank you too.

1 Like

Log file - big one and smaller Openhab2.log from Openhab restart time:

  1. Restart
  2. Wait to OpenHab full start ~1 min
  3. Delete association in Double WallMote
  4. Add association in Double WallMote
  5. 2x Wake up of Double WallMote
  6. Press the button of Double WallMote - mainly left one
  7. Delete rule responsible for turn on light
  8. Press the button again few times.

Hi Chris,
Did you have a chance to take a look at my log file?

Best regards

Sorry - I’ve been travelling on holiday over the past week or so with limited access to the internet. I will try and take a look over the next few days, but I really have limited time until after I get home late next week.

1 Like

At first glance, this appears to be working ok - the binding sets node 14 into the node 16 association group 2. It’s using multi-channel associations in this instance as that’s what the device supports.

However, this is really a messy part of ZWave and it may be that the device is not properly supporting the multi-instance-association class (There are 3 versions and a number of other implementations that are non-compliant).

I believe that when set in this way the command will be sent without encapsulation, but I’d need to check the docs and I don’t have them with me.

1 Like

Ok I will wait untill you will have more time. In mean time I’ve got second reply from Aeotec:

My suggestion is to try this.

1. Unpair WallMote Quad to reset everything back to defaults
2. Plug WallMote Quad on USB power near your Z-Wave Controller
3. Pair WallMote Quad
4. Associate devices that you want WallMote to control on group 2, 3, 4, 5, 6, 7, 8, 9
5. If you do not want scenes at all, remove all association on Group #1 (Node ID 1 should be assigned to this by default)
6. Confirm all associations are set in
7. Remove USB power and control and test in its placement.

​Make sure that the LED does not blink blue 3x times then red once, this would indicate that it failed to communicate to a device in its association.