Disabling or fine tuning logging

Is there a way to turn off logging for events and/or requests?


Yes. The logging is controlled by your logback.xml file. You can fine tune it on a class by class basis. The location of this file depends on how you installed openyHAB. If you did it by apt-get it is in /etc/openhab

The full documentation for logback is here. A good example of how to bump up the z-wave binding’s logging and move it to another file is at the bottom of this page. You can use this example to turn up or down any chunk of logging.

Thank @rlkoshak Sorry about the late reply.

I would like to re-activate this thread since I have trouble while deactivating event logs in order to reduce write operations to my file system.

I already followed these suggestions to comment out the bus event logger in the logback.xml file and/or the respective appender. (See https://community.openhab.org/t/large-events-log/10225/2 and https://community.openhab.org/t/large-events-log/10225/15). However, both resulted in openhab stopping after ~5 minutes. I also deleted the entire runtime.busevents section together with the eventfile appender section but also here openhab reproducibly stops after a few minutes.

Any ideas what’s going wrong here?

I’ve no idea. I only enable my event.log when I’m having trouble and I’ve never had any reliability issues with OH as a result. I just posted my full logback.xml here:

My bad! I found the issue and this has nothing to do with the logback.xml.

To monitor my server I installed monit (see https://mmonit.com/monit/) which checks for regular updates of the event.log file. Of course deactivating the event logs triggers the monitoring daemon to restart OH after some minutes because it does not see the event.log file being updated any more and assumes something is wrong with OH. After removing the monit-rule OH is now working as expected.

Nevertheless thanks for the quick response!