Disconnected from the openHAB Cloud service

hi,
google home and echo dot are saying that they cannot connect to openhab.
i have these errors/info in openhab

[INFO ] [.io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service [WARN ] 
[INFO ] [.io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service
[okhttp3.OkHttpClient                 ] - A connection to https://myopenhab.org/ was leaked. Did you forget to close a response body? To see where this was allocated, set the OkHttpClient logger level to FINE: Logger.getLogger(OkHttpClient.class.getName()).setLevel(Level.FINE);

Anybody seen a similar behavior?

1 Like

Dito

Same Problem:

2022-01-24 19:57:38.853 [ERROR] [io.openhabcloud.internal.CloudClient] - Error during communication

I‘ve got the same problem.
It started at 19:00 CET.

The status says everything is fine…

same

19:59:24.805 [INFO ] [.io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service (UUID = xxx, base URL = http://localhost:8080)
19:59:29.626 [ERROR] [.io.openhabcloud.internal.CloudClient] - Error during communication
19:59:29.628 [INFO ] [.io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = xxx base URL = http://localhost:8080)

Same here. Android app is obviously also not working

Also, same problem:

2022-01-24 19:13:51.227 [ERROR] [io.openhabcloud.internal.CloudClient] - Error during communication
2022-01-24 19:15:16.998 [ERROR] [io.openhabcloud.internal.CloudClient] - Error during communication
2022-01-24 19:15:42.526 [ERROR] [io.openhabcloud.internal.CloudClient] - Error during communication
2022-01-24 19:16:10.367 [ERROR] [io.openhabcloud.internal.CloudClient] - Error during communication
2022-01-24 19:16:30.991 [ERROR] [io.openhabcloud.internal.CloudClient] - Error during communication
2022-01-24 19:16:52.598 [ERROR] [io.openhabcloud.internal.CloudClient] - Error connecting to the openHAB Cloud instance. Reconnecting.
2022-01-24 19:18:07.932 [ERROR] [io.openhabcloud.internal.CloudClient] - Error during communication
2022-01-24 19:18:43.393 [ERROR] [io.openhabcloud.internal.CloudClient] - Error during communication
2022-01-24 19:19:28.592 [ERROR] [io.openhabcloud.internal.CloudClient] - Error connecting to the openHAB Cloud instance. Reconnecting.
2022-01-24 19:19:54.633 [ERROR] [io.openhabcloud.internal.CloudClient] - Error connecting to the openHAB Cloud instance. Reconnecting.

+1: same issue :pleading_face:

Why in such case live status does not report any issue?

i am such a noob…lost 1 hour just to find out that iam not the only one.Remind to self ,next time check community first! :slight_smile:

Same for me :cry:
Also Alexa is not working with OpenHAB. MyOpenhab website quite slow to open for me.
Strange that the iOS OpenHAB does not switch to the local URL - seems also additionally like a App bug.

Same issue for me

I’m getting the same issues. Phew, I thought it was just my setup :cold_sweat::joy:

Does someone know the correct place to raise an issue?
Is this correct or just for the selfhosted version?

Same here, I cannot also login to the myopenhab.org

Hi guys, we are looking at the issue, i don’t see any obvious issues other then it seemed like our servers were not reachable for some amount of time, which disconnected everyone, then the service became reachable, so all the OH instances tried logging in all at once, and its slowed our service down to almost a halt. I’m restarting services just as a precaution since i’m not 100% of the root issue. It will take a little time for everyone to get connected again.

6 Likes

Same issue here … I already tried to remove the cloud connector and reinstalled again. Without success.

Now there is a downtime visible …

To answer some of the questions above:

  • If your log shows your server repeatedly trying to connect to myopenhab and you haven’t made any changes, you can assume the server is down.
  • Outages don’t always show up on status.openhab.org. Sometimes, the issues are in between the myopenhab server and individual OH servers. This means that the server is up, but we can’t reach it.
  • Anything that’s reliant upon myopenhab (Alexa, Google Assistant, mobile apps, etc.) will not work until myopenhab is back online.
  • The community is the correct place to report an outage.

Should I make changes to my server?

No. Do not make changes to your system to try and get it to reconnect, as that may cause you additional problems. Just leave it alone. If it was working before, it will eventually start working again.

How do I report an outage?

If you see a lot of disconnect/connect reports in your log and believe myopenhab is down, do the following:

  1. Look for a banner like this one at the top of every page in the community.

If you see the banner, there’s nothing more you need to do. Someone’s already trying to fix the problem.

If you don’t see a banner:

  1. Check the community to see if anyone else has reported the outage today.
  2. Check status.openhab.org.
  3. If no one else has posted, then start a new post and tag it as “Apps & Services | openHAB Cloud”.
  4. Tag @digitaldan in your post so that he’ll be notified.

If someone has already started a thread, please don’t start another one (we don’t want to spam Dan with notifications). And if Dan has already posted that he’s looking into it, please don’t ask when it will be back up. He’ll always let us know as soon as it’s working again.

There’s also no need to add “same thing for me” posts, since everyone will be affected. If you want to get notifications, you can change your monitoring status to “Watching”.

image

Adding more comments notifies everyone who previously posted, and they’ll keep relentlessly checking in the hope that the issue has been fixed. Let’s save ourselves the stress. :wink:

How do I reconnect?

After myopenhab is back up, it can sometimes take a few hours for everyone to reconnect (because we’re all trying to connect at the same time). Please be patient while myopenhab catches up.

I’ve personally found that my server will always reconnect on its own. Sometimes, people have to restart the cloud connector to get that to happen.

  1. In Main UI, click on “openHAB Cloud”
  2. Don’t change any settings. Just click the “Save” button at the top right. This will stop and restart the connector, and you’ll see it in your log.

There’s no need to restart the connector if your log shows that your server is still trying to connect on its own. If that’s the case, there’s still too much traffic overwhelming myopenhab.

8 Likes

sorry it was not my intention to spam Dan, I have seen the other threads but they were all quite dated so I thought I could open a new one

No worries. I think you were the first to report it this time, so perfectly reasonable to do so.

I’m mostly trying to head off the rising sense of urgency and mild panic that tends to come with these threads. As soon as Dan is aware of the outage and working on it, we just need to be patient. But that’s hard for users who haven’t experienced this and don’t know what’s going on.

The funny thing is that there have probably been other outages that some folks have never noticed, because we were sleeping/working/etc. It just feels like a major issue as soon as we’re aware of it.

I may need to make an edit to my post, as I should have first checked with Dan that it’s okay to tag him. He’s never minded me doing that before when an outage occurs, but you’re right that we don’t want to overwhelm him while he’s trying to sort out the issues.

1 Like