Docker addon path

Hi,
I just set up Openhab on unRAID Docker with the official openhab/openhab 2.2.0 image. I have tried adding /openhab/addons and /usr/share/openhab2/addons mapped to a folder containing a .jar file file that works in another 2.2.0 installation. The Docker version of Openhab doesn’t want to load this addon. No error, Neato vacuum shows as uninitialized. If i connect to the docker (exec /bin/bash) and check both folders they both have the .jar file with 777 permissions.

root@tracer:/openhab# ls -lah /openhab/addons/
total 388K
drwxrwxrwx 1 openhab openhab   96 May 28 18:10 .
drwxr-xr-x 1 openhab openhab  208 May 28 13:47 ..
-rwxrwxrwx 1 openhab openhab 385K Apr 14 12:55 
org.openhab.binding.neato_2.0.0.201702202022.jar

(I am migrating to Docker from a virtual machine)

The proper place is /openhab/addons so you should be on the right path there.

Remove the file, then add it again while watching openhab.log. Do you see it attempt to pick up the binding and install it?

Tried removing the file and readding it as suggested. Nothing in tail -F /log/events.log /log/openhab.log. If i check /openhab/addons from within the docker the file is there with 777 permissions.

I also tried removing the /openhab/addons mapping in Docker and just copied the file into /openhab/addons manually within the running docker and changed the permissions. Nothing about addons in log.

root@tracer:/openhab# ls -lah addons/
total 392K
drwxr-xr-x 1 openhab openhab  108 May 29 19:46 .
drwxr-xr-x 1 openhab openhab  208 May 28 13:47 ..
-rwxrwxrwx 1 openhab openhab 385K May 29 19:46 org.openhab.binding.neato_2.2.0.jar
-rw-r--r-- 1 openhab openhab   70 Dec 18 12:24 README

Odd. It should see the file is there and pick it up. I wonder if the file system underlying the container isn’t providing the right file events, but then edits to the .items files et al wouldn’t work.

Presumably you’ve restarted the container since putting the jar file there?

I’m out of ideas.

Yes. Saving items or rules creates events in the logs. I have restarted the docker with the file in place as well. Anyone else? Its the last thing blocking me from getting rid of the old VM.

Any ideas please? Still an issue.

I’ve no further ideas. You could log into the karaf console and see if it sees the bundle and is just not installing it. I’ve never done that so look at https://www.openhab.org/docs/administration/console.html.

Maybe the openHAB 1.x Compatibility Layer needs to be installed.

It has some dependencies that need to be installed before you can use it. Installing the HTTP Binding will most likely install the required dependencies.

@maciekish did you ever solve this? I’m having the same problem…

Same problem here. Any new solution so far?

Similar issue reported (and solved) in an other thread by @Raven:


I hope it helps!

I experience the same issue. I tried both things to mount addons and upload files to the folder, and also from docker level I had files in other folder and then I have upload them to non mounted addons folder with correct permissions - no luck so far