Docker and myopenhab not working

  • Platform information:
    • Hardware: _x86_64
    • OS: Fedora 27
    • Java Runtime Environment: Zulu 1.8.0_144
    • openHAB version: 2.2
  • Issue of the topic:
    I am using a Docker version of Openhab2 that comes with Zulu JDK.
    I configured the openhabcloud and when I visit, status is shown as ‘Online’. However, when I click on the ‘dashboard’ link on the webpage, I get this error:
    openHAB connection error: Connection refused
    My local log files show:
    2018-02-25 01:23:19.823 [ERROR] [io.openhabcloud.internal.CloudClient] - Connection refused
    2018-02-25 01:23:19.824 [WARN ] [io.openhabcloud.internal.CloudClient] - Jetty request 1796288 failed: Connection refused

I doubled checked the uuid/secret to make sure it was correct.
My local web interface is working fine. It’s just the remote connection that’s not working preventing my from accessing home devices when I am away from home.

I tried changing log levels but I cannot get any addition information.
Could this be causing the problem? :
openhab.log:2018-02-25 00:56:29.918 [WARN ] [.jetty.internal.ServerControllerImpl] - SSL password and SSL keystore password must be set in order to enable SSL.
openhab.log:2018-02-25 00:56:29.926 [WARN ] [.jetty.internal.ServerControllerImpl] - SSL connector will not be started

I created a new ssl cert and new keystore both of which were using a password. However, I couldn’t figure out where to store the password so that jetty would find it. I tried various places but the log files would just show that wrong password was used and jetty wouldn’t start.

What else can I try? I am running out of ideas.

I’m facing exactly this. Any updates?

But on openHAB 3.4.4 with podman on Fedora Linux 37

2023-07-09 10:28:54.417 [INFO ] [io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service (UUID = 61...e9, base URL = http://localhost:8080)

But running netstat -ln | grep 8080

tcp6       0      0       :::*                    LISTEN

So cloudconnector listens on localhost, and there is no instance exposed.

the solution was, to not specify a OPENHAB_HTTP_ADDRESS. Then openhab exposes 8080 to all interfaces.