Docker image no longer building

Has anyone else noticed the docker image is no longer updating within cloudless? I think it is over 40 days old now. I just did a pull, and it says build 791. I think the main distro is on 828 or something now.

Does anyone know how I can build the image myself? There are directions on the docker hub to do the docker build…but before that it says checkout the github repository…but I can’t figure out the url for that either which has the Dockerfile.

Are you pulling 2.1.0-snapshot? If not you are only getting the 2.0 release. Build 791 feels about right for the 2.0 final release. Change which label you are pulling to 2.1.0-snapshot to get the nightlies.

The github repo is here.

All of the main openhab projects can be found under the openhab account.

I am using the 2.1.0 snapshot.

The build server seems hosed for now. Shortly after I posted my topic, someone gave the docker project a nudge of some sort so it is now building. I can now get build 826 which is closer to most recent.

However, currently openHAB-Distribution jobs are aborting, starting at build 826. And that job is upstream to the docker job.

I saw someone else posted a day or two ago about the issue with the build server. So hopefully it will get figured out soon. Want to try that new marketplace binding that Kai announced.

I just pulled down the docker project and modified the Dockerfile to pull directly from build 838 of the distribution project on the cloudbees server, so now I have access to IOT Marketplace. Works until the build server gets repaired.

I think the community would benefit from a brief tutorial on how to build their own Docker image from the GitHub source. In particular what you did to point it at a specific build.

Good idea Rich.

Here is the tutorial

1 Like

Hi Rich,

Do you know who is responsible for the docker builds? I have been trying to find out why it is only the amd images that are now being pushed up to the docker registry. Been over 3 weeks since a armhf image has been produced.


Post an issue on the openhab-docker github and someone will see it.

tried that already. no one has responded in over a week. also tried posting a topic here on the forums.

if anyone else uses the armhf docker image, for now I am building it myself.

you can get it here on the docker registry: craigham/openhab::2.1.0-snapshot-armhf

I’ll try to keep it pretty up to date.

The maintainers for the docker repo are @cniweb and @cyberkov , perhaps they might be able to answer your questions. builds the images as far as I understand, as you say it looks like there’s a problem with armhf.


runtime: failed to create new OS thread (have 2 already; errno=22)