Docker openhab:3.2.0-snapshot stuck at unhealthy with OpenJDK Client VM warning: No monotonic clock was available

Raspberry Pi 4, Docker Engine - 20.10.10
as the title suggest, I just pulled the latest 3.2.0-snapshot and when I start the openhab I am getting this entry and the container state is either stuck at “starting” or “unhealthy”. not sure if that JDK error is the issue or not. any thoughts?

Launching the openHAB runtime...
OpenJDK Client VM warning: No monotonic clock was available - timed services may be adversely affected if the time-of-day clock changes

please see this link for reference : How to solve Gradle docker image freezing on Raspberry Pi with warning about monotonic clock? - Stack Overflow

no one? 3.1.0 runs fine in docker…

Currently, I run 3.2M3 in docker with no issues at all. I have have run previous 3.2 snapshots also with no issues. I do not run docker on a rpi, however, and that is usually discouraged as I understand it.

Based on the reference you found, it is not surprising that you are seeing this issue (although I don’t know what changed in 3.2 to require the libseccomp library).

Have you tried following the solution that is also in the link?

Try updating seccomp on your Docker host as is suggested in all the links @Rathna-K .

All Linux distros are preparing for the end of time so thats probably why it wants a “monotonic clock”. The recent openHAB Docker 3.2.0-SNAPSHOT images use Debian 11 which is probably better prepared for the end of time.

If you’ve tried the Alpine image on the 32-bit Raspberry Pi OS recently you would most likely have run into similar issues. See: Release Notes for Alpine 3.13.0 - Alpine Linux

1 Like

Installing the package in my original link in the docker host solved the problem.

1 Like


just an interesting finding I just had:

I ran into the very same issue when upgrading from OH3.1.0 to OH3.1.1. When downgrading again to OH3.1.0 everything worked fine again?!
I run OH on a RasPi 4 in Docker

1 Like

I had the same Problem with Rp4 and Docker, its the same solutions like above…

My Solution for that

#Add dep Key
sudo apt-key adv --keyserver --recv-keys 04EE7237B7D453EC 648ACFD622F3D138
#Add dep 
sudo echo 'deb buster-backports main contrib non-free' | sudo tee -a /etc/apt/sources.list.d/debian-backports.list
#Update and Install
sudo apt update
sudo apt install libseccomp2 -t buster-backports

Thats works for me


It worked for me too. @klementuel Thank you for the instructions.

My settings
Raspberry 4
Downloads · Docker Pirates ARMed with explosive stuff (Version 1.12.3)
Docker Image: openhab/openhab:3.1.1

Just to be sure: you are doing that in the Docker host, not the container?
For some reason this didn’t help in my case.

Yes on the host…
Maybe a rebuild openhab container will help?

Or maybe just a host reboot

I executed the lines on the host (not the docker container) and executed a reboot. That worked for me. :smiley:


1 Like