Docker [Synology NAS] 3.2. to 3.3 - setup issue: "Could not determine addons folder"

Today I tried to upgrade from 3.2 to 3.3.
I’m running openHAB in a docker container on my Synology NAS.

As usual, I created a new docker instance as I planned to just copy the 3.2 data folders to the new file location.
But it always ends up in this

2022-08-10 15:23:29.426 [WARN ] [core.karaf.internal.FeatureInstaller] - Could not determine addons folder, its content or the list of installed repositories!
2022-08-10 15:23:29.427 [INFO ] [core.karaf.internal.FeatureInstaller] - Some .kar files are not installed yet. Delaying add-on installation by 15s.

I already looked at the other posts here but none could help.
So I tried to setup the container freshly just to see if that works and - nope - does not work too. Same issue.

What I did

  1. created docker container with this environment parameters:

user 1040 (openhab) and group 100 (users) exists on my NAS system

  1. I created the folders addons, userdata and config
  2. I changed the owner of those folders to openhab:users
  3. started the container new

Initial files have been created now but I still, the error exists.

I’m running out of ideas what can be wrong as I tried it with a new container setup now too.

I still think it may be related to some read/write issues but I don’t know what else to try.
Ideas/hints are appreciated.

I’ve seen that during startup openhab still seems to apply a wrong user group?

is this an issue? if so, how can I solve it as it seems it’s not using the group provided in the environment parameters.

OK, I think i found a solution for my issue.
Basically I did it like described here Docker Restarting: KARAF_ETC is not valid: /openhab/userdata/etc but that still ended up in the above issue.

I then realized that I may have started the container initially without the user/group of the NAS but I thought since I’m shutting down the container it will recreate everything internally. As to my knowledge this is the default behavior of docker containers (to not store data internally).
It seems the Synology docker app is still keeping this.

So I had to select the container in the Docker app and click action > reset (hope it is called this way in English as well as I have it set to German where it is Aktion > Zurücksetzen).
This really cleans the complete container and after restart I see that the user & group are now taken over.