Does Homematic binding support multiple CCUs?

Tags: #<Tag:0x00007fc1fe0f6ed8> #<Tag:0x00007fc1fe0f6e10>

I have two CCUs and would like to control them both from OpenHAB (I have 2.5.1). I used to have a LAN Gateway, which was fine for traditional Homematic devices, but it does not support Homematic IP devices, which I now have at various places in my house. So I decided to try installing a second CCU3 instead.

Sadly, although the second eQ3-HmIP-CCU3-App is discovered by OH, it spends ages in the Installing state before ending up in the state OFFLINE - COMMUNICATION_ERROR, complaining about Unknown XML-RPC tag: title.

The first CCU (a vanilla EQ3 CCU3) starts up OK with the following in openhab.log:

2020-02-15 01:44:44.749 [INFO ] [ternal.communicator.client.RpcClient] - Interface 'WIRED' on gateway '3014F711A0001F9A49922D87' not available, disabling support
2020-02-15 01:44:44.926 [INFO ] [ternal.communicator.client.RpcClient] - Interface 'CUXD' on gateway '3014F711A0001F9A49922D87' not available, disabling support
2020-02-15 01:44:45.415 [INFO ] [ommunicator.AbstractHomematicGateway] - HmGatewayInfo[id=CCU,type=CCU2,firmware=3.51.6,address=QEQ0574855,rf=true,wired=false,hmip=true,cuxd=false,group=true]

The second CCU (a Raspberrymatic on a Raspberry Pi 3B+) doesn’t make it and leaves the following in openhab.log:

2020-02-15 02:03:16.682 [WARN ] [core.thing.internal.ThingManagerImpl] - Disposing handler for thing 'homematic:bridge:3014F711A0001F58A9A72142' takes more than 5000ms.
2020-02-15 02:03:22.713 [WARN ] [.core.thing.binding.BaseThingHandler] - Handler HomematicBridgeHandler tried updating the thing status although the handler was already disposed.
2020-02-15 02:03:23.898 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing 'homematic:bridge:3014F711A0001F58A9A72142' to inbox.

Is there some special trick to enabling two CCUs in OH? Or is it not possible?

Regards,
Steve

I don’t know whether anyone has really tried to use two CCUs at the same time. Did you try to switch off your first (working) CCU and test whether the second CCU works OK if it is the only running CCU?.

I can imagine that there is a problem with the callback ports if two bridges are trying to use the same ports. BTW there is a hint in the binding’s documentation regarding the port configuration:

  • xmlCallbackPort Callback port of the binding’s XML-RPC server, default is 9125 and counts up for each additional bridge
  • binCallbackPort Callback port of the binding’s BIN-RPC server, default is 9126 and counts up for each additional bridge

If the second CCU works fine if it is running alone you could enable and add your first CCU. If the problem occurs again please enable the TRACE mode and post the log file. Maybe we can see a bit more.

Thank you for your tips, @MHerbst! I can now confirm that the Homematic binding does indeed support multiple CCUs. I now have two active CCUs, serving different parts of my house.

I thought I had set up both CCUs identically, but I had overlooked one thing: in Settings / Control Panel / Security there is a little box labelled “Authentication active”, which I had not removed the tick from. Once I had done that, everything worked perfectly.

I tried a number of other things before that, however, but they were all unnecessary as it turned out. Mostly they were configurations options in /etc/openhab2/things/homematic.things. What I discovered:

  1. you don’t need to provide settings for xmlCallbackPort or bindCallbackPort: OH seems to manage on the basis of the default settings;

  2. creating an entry for a Homematic binding in homematic.things causes an extra Thing to be created in addition to the eQ3-HmIP-CCU3-App - 192.168.nnn.nnn Thing instead of repurposing the eQ3-... Thing, which I found confusing.

So, bring on the next problem :slight_smile:

Steve

1 Like