Don't get full list of bindings


I run OH on a Debian machine for a while now and switched to OH2 last January.
I use the stable repository: 'deb stable main’
But for some reason I cannot get the latest bindings. In the Paper UI I cannot see the eKey binding and the Zoneminder binding for example. They also do not show up in the feature list or bundle list in the Karaf console.
I did re-install OH2 now several times, but nothing seems to help.

I would be glad if someone can tell me what stupid mistake I am doing…


I’m trying to push this up again as the problem still persists.
Anybody able to help?

No one with an idea??

Have you tried the snapshot release to see if you have the same problem?

Check also if you have enabled the “Access Remote Repository” in PaperUI->Configuration->System

What is the output of the following:

java -version

No, haven’t tried yet.

Is enabled.

java version "1.8.0_131"
Java(TM) SE Runtime Enviroment (build 1.8.0_131-b11)
Java HotSpot(TM) 64-Bit Server VM (build 25.131-b11, mixed mode)

Well… I just tried out 2.0.0 Stable Release Build on a Windoze machine and I also don’t see these 2 bindings…

Maybe… just maybe… there are not supposed to show up ?
I believe that the 2.0.0 Stable OH2 core will only show 2.0.0 version bindings that were available at the time of the 2.0.0 release… (from the Release Build online repo)

If you want to access the latest 2.1.x bindings, you should switch from the stable to the snapshot core.

There is always the possibility to stay on OH2 Stable core and use 2.1.x Snapshot bindings, but this is not recommended since some improvements that may be required by the 2.1.x bindings could be found only in the 2.1.x snapshot core.

Ps: If you go to snapshot (which I recommend), the online repo is now @ Online Repo for Snapshots has moved to Artifactory

OK, thanks.
I’ll try that over the weekend.
In order to do so, I only need to amend /etc/apt/sources.list.d/openhab2.list and run:
> sudo apt-get update

    sudo apt-get install openhab2
    sudo apt-get install openhab2-addons



See more details here: (use the unstable repo)

Note: You could skip your 3rd installation step for the openhab2-addons package and use the online repo to access the bindings.

If I did install before, should I un-install? Is this maybe the root-cause for the whole issue?

No, this is not the root-cause.

I believe (but I am not 100% sure) that currently (on 2.0.0), you will only see the bindings that were available at the moment of the 2.0.0 Release Build of openHAB (independent if you have installed the offline addons bundle or you are accessing the online repo for the addons)

Proof of the above statement is the list that can be found on the online repo here: (the currently active 2.0.0 online repo for bindings)

Before you upgrade from 2.0.0 Stable to 2.1.0 Snapshot (by using apt-get install openhab2 from the unstable repository), you should remove the old 2.0.0 offline addons package (apt-get remove openhab2-addons).