Doorbird - doorbell does not work anymore... OH 2.5.11

Hi all,

I am getting weird… ;-). Since a reinstall - because of another problem - my doorbird does not work like i want it to.
The thing is showed only. The DoorbellMotion-Item works fine. But the DoorbellPressed does not work… and everything is correct, or i am blind.

Thing doorbird:d101:doorbell “Doorbird D101 Doorbell Erbstadt” [doorbirdHost=“myip]”,userId=“ghalac0000”,userPassword=“mypassword]”,imageRefreshRate=60,doorbellOffDelay=3,motionOffDelay=30,montageNumImages=3,montageScaleFactor=35]

Switch DoorbellPressed "Doorbell Pressed [%s]" <switch> { channel="doorbird:d101:doorbell:doorbell" [profile="rawbutton-on-off-switch"] }

Switch DoorbellMotion “Doorbell Motion [%s]” { channel=“doorbird:d101:doorbell:motion” }
DateTime DoorbellPressedTimestamp “Doorbell Pressed Timestamp [%1$tA, %1$tm/%1$td/%1$tY %1$tl:%1$tM %1$tp]” { channel=“doorbird:d101:doorbell:doorbellTimestamp” }
Image DoorbellPressedImage “Doorbell Pressed Image [%s]” { channel=“doorbird:d101:doorbell:doorbellImage” }
DateTime DoorbellMotionTimestamp “Doorbell Motion Timestamp [%1$tA, %1$tm/%1$td/%1$tY %1$tl:%1$tM %1$tp]” { channel=“doorbird:d101:doorbell:motionTimestamp” }
Image DoorbellMotionDetectedImage “Motion Detected Image [%s]” { channel=“doorbird:d101:doorbell:motionImage” }
Switch DoorbellLight “Doorbell Light [%s]” { channel=“doorbird:d101:doorbell:light”, expire=“5s,command=OFF” }
Switch DoorbellOpenDoor1 “Doorbell Open Door 1 [%s]” { channel=“doorbird:d101:doorbell:openDoor1”, expire=“5s,command=OFF” }
Image DoorbellImage “Doorbell Image [%s]” { channel=“doorbird:d101:doorbell:image” }
Number DoorbellDoorbellHistoryIndex “Doorbell History Index [%.0f]” { channel=“doorbird:d101:doorbell:doorbellHistoryIndex” }
DateTime DoorbellDoorbellHistoryTimestamp “Doorbell History Timestamp [%1$tA, %1$tm/%1$td/%1$tY %1$tl:%1$tM %1$tp]” { channel=“doorbird:d101:doorbell:doorbellHistoryTimestamp” }
Image DoorbellDoorbellHistoryImage “Doorbell History Image [%s]” { channel=“doorbird:d101:doorbell:doorbellHistoryImage” }
Number DoorbellMotionHistoryIndex “Motion History Index [%.0f]” { channel=“doorbird:d101:doorbell:motionHistoryIndex” }
DateTime DoorbellMotionHistoryTimestamp “Motion History Timestamp [%1$tA, %1$tm/%1$td/%1$tY %1$tl:%1$tM %1$tp]” { channel=“doorbird:d101:doorbell:motionHistoryTimestamp” }
Image DoorbellMotionHistoryImage “Motion History Image [%s]” { channel=“doorbird:d101:doorbell:motionHistoryImage” }
Image DoorbellDoorbellMontage “Doorbell History Montage [%s]” { channel=“doorbird:d101:doorbell:doorbellMontage” }
Image DoorbellMotionMontage “Motion History Montage [%s]” { channel=“doorbird:d101:doorbell:motionMontage” }

For example a rule … something like my personal goal:

rule "DoorBirdEventKlingel"

Item DoorbellPressed changed to ON
logInfo(“doorbird”, “Ein Besucher klingelt.”)
echo_beamer_TTS.sendCommand(“Ein Besucher steht vor der Tür.”)
echo_masterbad_TTS.sendCommand(“Ein Besucher steht vor der Tür.”)
echo_gaestebad_TTS.sendCommand(“Ein Besucher steht vor der Tür.”)
echo_schlafzimmer_TTS.sendCommand(“Ein Besucher steht vor der Tür.”)
echo_studio_TTS.sendCommand(“Ein Besucher steht vor der Tür.”)

The logfile shows that, when i ring the bell:

2020-12-29 18:15:18.082 [vent.ItemStateChangedEvent] - DoorbellMotion changed from OFF to ON

But neither DoorbellPressed is triggered, not p. ex. the DoorbellPressedTimestamp is updated.

I already cleared the cache and rebootet the system several times.

Thanks for every little clue!!!


Thing is named doorbell. Channel also is named doorbell.

I did this once myself and I wrote the damn binding. lol

1 Like

@mhilbush: What do you mean? Should @ByteBandito change his ‘Thing’ configuration?

To me the configuration looks correct and matches the documentation from I use the same analogously.

I’ve had the same problem with doorbird binding for a while and took care of it today. The problem with me was the user’s permissions, which is used in the configuration. This user needs the authorizations as ‘API operator’. Possibly the authorizations have changed with an update of the app? For me, setting the permissions in the app solved the problem.

@ByteBandito: Can you check this?

Ugh! I was in too much of a hurry. No, the Thing definition is correct. And the DoorbellPressed item definition is correct, too.

Good suggestion. Thanks! And thanks for checking my work. :wink:

Thanks Mark!

I used the wrong existing user :-). But what I still dont understand: Why did Motiondectected work?

Anyway: Now it works like a charm! Thanks again… also at Gordon for writing this great binding.

Glad you got it sorted out.

Actually, Gordon solved your problem, and I wrote the binding. :wink: