Doorbird items not working anymore after updating to 2.5.8

Tags: #<Tag:0x00007f6170429518>

After updating from 2.5.7 to 2.5.8 i had some issues…still not soluted is the doorbird problem. i have the thing online in paperui, in the log it will be loaded without problems… i only have some error logs like: Cannot retrieve item “Doorbell_MotionImage for widget”… i also created some custom widget with this items to sho in hab panel…
but in the standard sitemap no images are shown too and i cannot open the door or something else… it seems that there is no connection.
any idea ?
could it be the new 2.5.8 binding? maybe a bug ? cannor i downgrade to the 2.5.7 binding and if, how ?

thanks for help,

oliver

This means the openHAB framework cannot find the Item by that name. The message is usually prompted by a UI asking to display it.
This has nothing to do with any bindings.

“Missing Items” are often seen after an upgrade, when the system cache has been cleared. It sometimes takes 2 or 3 restarts to repopulate that cache.

No open issues on Github so try @rossko57 advise.

If you need to clean cache again:

sudo systemctl stop openhab2

sudo openhab-cli clean-cache

sudo systemctl start openhab2

Then a few restarts with sudo systemctl restart openhab2 but give OH time to fully load up between each restart.

If you want to down grade the binding version then uninstall it from PaperUI and use a jar file. Place the jar in usr/share/openhab2/addons then restart OH.

Here’s a list of jar files. https://openhab.jfrog.io/openhab/libs-pullrequest-local/org/openhab/addons/bundles/org.openhab.binding.doorbird/

I didn’t advise to clean cache yet. The upgrade already did that, now we want to make sure it is repopulated.

1 Like

Sorry, edited the post. :upside_down_face:

In the past I have needed to clean the cache after an upgrade although I know it’s cleaned in the update process.

Thanks guys, will check this but i made already 4 or 5 restarts… and nothing! i think i will try to downgrade! i use openhab in containerstation on a qnap nas… works already fine… except after this upgrade…
i will report tomorrow.

That should rule the cache out. (Of course if you downgrade you will need to take it into account again.)

Are your Items defined by file? What does your openhab.log say about loading that file?

The items are defined well in the item file, all is loaded well…:

2020-09-05 09:15:02.283 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Locale set to 'de_DE'.
2020-09-05 09:15:11.582 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'doorbird.items'
2020-09-05 09:15:11.734 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'fritzboxtr064.items'
2020-09-05 09:15:12.030 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'knx.items'
2020-09-05 09:15:12.383 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'samsung.items'
2020-09-05 09:15:12.473 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'sma.items'
2020-09-05 09:15:12.663 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'sonos.items'
2020-09-05 09:15:12.798 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'standard.items'
2020-09-05 09:15:12.907 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'textinput.items'
2020-09-05 09:15:12.935 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'unifi.items'
2020-09-05 09:15:12.998 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'vallox.items'
2020-09-05 09:15:13.068 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'wibeee.items'
2020-09-05 09:15:14.345 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'default.sitemap'
2020-09-05 09:15:14.350 [WARN ] [el.core.internal.ModelRepositoryImpl] - Configuration model 'default.sitemap' is either empty or cannot be parsed correctly!
2020-09-05 09:15:14.554 [INFO ] [el.core.internal.ModelRepositoryImpl] - Validation issues found in configuration model 'standard.sitemap', using it anyway:
Sitemap should contain either only frames or none at all
2020-09-05 09:15:14.558 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'standard.sitemap'
2020-09-05 09:15:15.233 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'sonos.things'
2020-09-05 09:15:15.281 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'standard.things'
2020-09-05 09:15:15.357 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'knx.things'
2020-09-05 09:15:15.458 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'sma.things'
2020-09-05 09:15:15.507 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'doorbird.things'
2020-09-05 09:15:15.529 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'samsung.things'
2020-09-05 09:15:15.545 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'openweather.things'
2020-09-05 09:15:15.559 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'vallox.things'
2020-09-05 09:15:22.938 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'textinput.rules'
2020-09-05 09:15:23.577 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'unifi.rules'
2020-09-05 09:15:23.695 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'doorbird.rules'
2020-09-05 09:15:25.615 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'anwesenheit-check.rules'

solved! i missed an additionalname from the things config in the items names… but strange: i didnt changed something and in 2.5.7 it was running…
thanks

oliver