Dsmr binding off line, Serial port already in use

As mentioned here, I will write down my experience withe the new dsmr binding here.
I installed the new dsmr-binding which almost worked out of the box. I tryed to fiddle with the serial-port settings to get all things working but did not succeed. I moved on to the items and my sitepoint and forgot about the non-working things.
After some time, my OH-laptop rebooted after which the binding was completely off line and I got the error: Serial port already in use.
This lead me to the configuration of serial port, but my system (standard Debian 9) does not contain the mention files and I first wanted to ask about that. But I tried to start over first:
deleted things and binding, reinstalled binding and search for things: discovered 5 things:

Algemene DSMR Meter
M3 Meter
Slimme meter
Slimme meter

I excepted all things in the in-box. Now come my questions:

In config 'Elektriciteitsmeter, I can choose two bridges 0, or 22e5393(why?)
First Thing ‘Slimme meter’ is off line and connected to bridge 1 (which I cannot change). In config I can choose serial Port 0, ttyUSB1, or ttyACM0
The second Thing ‘Slimme meter’ is online and connected to the bridge 22e5393
All is working, also after sevral reboots.

I know there is a bridge-thing (Algemene DSMR Meter) and in my case a thing for electricity and one for gas. But what are the other two things ‘Slimme meter’ for?
And why can I set the USB-setting in PaperUI for the off-line ‘Slimme meter’ while this results in a non-functioning DSMR-binding after the next boot?

1 Like

These ‘slimme meter’ are the bridges, which explains why you can’t change what bridge it is connected to. Meaning you have 2 bridges. The ‘Algemene DSMR Meter’ is not the bridge but a generic thing that has channels with generic information, like dsmr type, last reading time. Because it depends on what kind of meter you have this is not available in the bridge. This makes the bridge independent of the actual meter and only contains the serial configuration.
I don’t know how you ended up with 2 bridges. But if you configure the serial port to an existing but not used port on the non functional bridge than on reboot it might be due to the order of which the serial ports are assigned to usb ports (it can change between usb0 and usb1) the non functional bridge than contains the configuration for what is at that moment the usb port connected to the actual meter. and than it doesn’t work.

1 Like

Hello Hilbrand,
Thank you for your explanation. Does this mean I can just delete the ‘Slimme meter’ that is off-line?

Yes you can remove it. Did you do a discrovery and ended up with these 5 things or did was it added some other time/way? And if it was added during discovery does it reappear in your inbox after you’ve removed it and started a new discovery (in PaperUI)?

I believe they were all there the first time, but I cannot be 100% sure.
I deleted the Thing and it doesn’t come back when I click ‘discover’. So I guess I must be wrong and it must have come the second time round. This would mean I really don’t know why it didn’t work after first reboot, or why it keeps working now. But I am glad it is working now!