DSMR binding smart meter openHAB 3 fails

Dear openHAB community,

I am trying to connect openHAB 3.0.0 on a Raspberry PI to my digital smart meter T211. This should be possible with the DSRM binding. It’s connected with a RJ12 to USB cable and the telegram with values are visible with command cat /dev/ttyUSB0.

‘Invalid value for MonthOfYear (valid values 1 - 12): 25’

In the past with OH version 2.5.2 it worked, but not without adding a DSRM binding from the Eclipse IoT market. For some reason the Eclipse market addon is no longer available in OH 3

Does anyone know how to fix this issue?

Thank you very much for your help.

Best regards,


If it worked before it look likes it’s a conflict with latter added support. Can you run the binding with with log level trace. This should show the raw data (a telegram). Can you send that to me via private message here on the forum so I can analyse what goes wrong.

The Eclipse market place is not supported anymore as it’s related to Eclipse Smart Home. There are ideas to add something new in openHAB. But this explains why you can’t find it. The Eclipse Market place is still online available, but OH 2 bindings don’t run on OH 3.

This issue has be resolved and a pull request has been created.

This issue here is that the gasmeter for some reason reports, instead of the date, the value 632525252525W. This seems to happen more (based on some searching on this value) and might indicate a problem with the meter not correctly reporting the data.

1 Like