DST/Astro not functioning

OH 2.5.11

Seems like since the time change, Astro is no longer working.
Any ideas what would cause that; where to look/configure?

Thanks

What does “Astro is no longer working” mean?

If Astro is off by an hour, then the problem is most likely that your server has not updated its clock. It would typically synchronize to an NTP server or your router.

A bit more of input is required to really help.
What exactly does

mean ?
Going to the doctors you also need to tell more about why you are visiting the doctor.
Same for the garage if you bring your car in - apart of for the regular control.

Could be different reasons but more info is needed

  • was it working before ?
  • when did it work the last time ( change between DST periods ) ?
  • was there a recent change in your local DST change date ?
  • which DST zone do you live in ?
  • what is the underlying OS ? Is it may be outdated and does not have current DST rules ?
  • logging in to the OS console; entering date; does it show your current time ?

Just doing

is not enough. NTP submits the seconds since epoch. The timezone setting of the OS/Java is required to format the date/time according to the local ‘offset’ from UTC/GMT.

Sorry,
Time on the ubuntu machine is correct…it changed over with the time change.
Was it working before-yes
When did it work last time - all i can tell you is when i noticed it not working; yesterday(2 days after time change); but maybe b/c i hadn’t paid attention to rules that run after “sunset”
Was there a recent change - yes, sunday
TimeZone EST
Ubuntu 20.04.1
Yes, shows current time

Did you already try to restart openHAB or just the Astro bundle to see if that fixes your issues? There were many fixes in the Astro Binding since OH 2.5.11, so maybe upgrade before the next DST change. :slight_smile:

2 Likes

Good point. I was just speaking to the time change, since it appeared that the OS previously had the correct time. But it would have been possible that it was set to a time zone that doesn’t have Daylight Savings Time.

I did once. But twice apparrently works better.Thanks

1 Like