[Duplicate] Google Assistant lies to me

Same issue here, ON command results in “sorry…” response but a successful state change, OFF and % commands are fine.

Been using it without issue for many months, without and software or configuration changes on my side, hard to say when I first noticed the issue (maybe in the past 2 months), but it is persistent now.

+1 here. It’s been driving all the family crazy!! And I’ve just changed from Amazon Alexa to Google Home as I got fed up - but this is now makes Google Home worse! I’ve seen some posts on github here

…so someone has found a solution, but I’m not sure how we apply this - possibly it gets picked up at next integration?

I find it very odd some of you have this issue and others (me) dont.
I´m pretty sure its a Google issue and not something openhab can do anything about. Mainly because not all of us are having this issue. If it is correct, then there really isnt anything openhab (or anyone else) can do to fix it.
Please note, I use voice commands alot for almost everything in my home. I have not experienced this issue a single time, (yet).

Yep exactly the same issue here. Unlinked all OpenHAB services from Google home tonight and relinked to no avail… Just the ON commands that give the “I can’t reach…” response even though the commands work anyway…

Maybe will open a case with google seeing as how many people are seeing the same issues here…

Strange why no one care about fixing it or at least pointing out the root cause of this annoying problem.

Authors, maintainers, expert users, if you think the public OH cloud setup has an issue and will take too long to get patched, it would be a very kind of you to inform us here. Perhaps we can setup our own cloud if this is an option.

Awaiting your response.
Thanks

see here (124 posts… you were warned)

and here for new alternative

As mentioned above (and indicating). I dont think this is an openhab cloud issue. I truely believe it´s a google issue. So there may not be anything for openhab maintainers to fix.

But I agree with you, it would be nice if someone at least could make a comment about it. No words are worrying words!

And I don’t believe that this is google issue. Another user was having similar problems, rewrote the whole implementation and the problem is gone https://github.com/openhab/openhab-google-assistant/issues/44#issuecomment-502614946

I hear you. But how come I dont experience the same issue then? I believe openhab cloud is equal for all of us. While google operates in regions.

Perhaps recently Google did an update on their code that broke OH google-assistant and caused this problem for some users but other users were not affected because (although my assumption :thinking:) the update didn’t propagate in some regions like yours, mine and others.

Google Cloud Function <-> myopenHab <-> local openHAB . We have three different systems here. Is the Implementation correct (afaik at least to a couple of days a go it was not according to docs regarding to return value)? What about network latency ?

There does not seem to be issues regarding this on public google issue tracking https://issuetracker.google.com/issues?q=componentid:655104%20can't%20reach so is openHAB so unique that issues arise only for their users?

Of course it might be google problem. E.g. there is a known issue with English grammar and some modes - you cannot say What Cycle is the Washer On (it will fail with Sorry, can’t reach) but you must instead use What is the Washer Cycle? though saying What Temperature is the Washer On is perfectly fine.

But this is just guessing. Troubleshooting should start from investigating StackDriver logs for Google Cloud Functions.

Two of those are the same for openhab users.

I have no idea. I have filed the issue I´ve got, which is regarding temperature (thermostat) mode showen on a Nest Hub will fail. Beside that, I´m not aware of any issues. And infact that issue I mention is probably also caused but some changes at Google side. The thermostat mode works fine in the Google Home App. Controlling the thermostat by voice is working fine as well. So, something is different when using a Nest hub. My guess is, only Google knows whats going on.

Regard latenzy, I have no idea how this would affect any users at all.

Which is not precisely correcly, since it doesnt affect me (and probably others as well)… I agree its a mystery / strange.
I also agree, there should be some statement from someone. Unfortunatly it doesnt really seem to concern anyone, (at least not in the open space. I have no idea whats going on behind the scene of openhab). I know the usual maintainer of the service has either left, or is quite busy, which he said in another thread. Thats probably all we (ordinary users) know.

Hmm, just to let you know… I did some digging into this matter. And I actually managed to receive the issue here. It´s highly strange indeed.

I asked (by voice) google to change the temperature in my office (where I´m sitting right now). Google respond with the same frase and issue you´re having “unable to connect to openhab”. But the temperature (setpoint) did indeed change:

2019-10-30 22:15:58.123 [ome.event.ItemCommandEvent] - Item 'kontor_Tempsetpunkt' received command 22
2019-10-30 22:15:58.433 [vent.ItemStateChangedEvent] - kontor_Tempsetpunkt changed from 21.00 to 22.00

I then asked google to turn off the light at the office. Google responded with “okay turning of the light” and the light turned off.
The I asked Google to turn on the light, Then I recived a “pling”" which means it has done it cause the GH mini is placed rigth next to me in the office. And the light turned on…

I repeated this several times. No issues.

I then tried the temperatur (setpoint) change again… And again I receive the respond “unable to connect to openhab”, but the temperature (setpoint) did indeed change again, just fine.

2019-10-30 22:21:50.491 [ome.event.ItemCommandEvent] - Item 'kontor_Tempsetpunkt' received command 21
2019-10-30 22:21:50.774 [vent.ItemStateChangedEvent] - kontor_Tempsetpunkt changed from 22.00 to 21.00

So right now it seems, I have no issue with “Ligthing” and Switchable tags. But “TargetTemperature” seems to be an issue, for me.

I then asked Google about the temperature ( “CurrentTemperature” tag). It worked, BUT! It gives a very strange result, as “she” gives me three temperature values.
One for the actual temperature,
Second for the actual setpoint,
The third value I have no idea where this came from. She said 24 degree celcius. And it doesnt make any sense.
I grapped my phone and copied the text from my activity… (this is a good tip to use when having problems).
This is the fully respond I´d get: (translated into english)

The heating is set to 21 degrees at the Office Thermostat with a current temperature of 23.5 degrees.
Right now there are 24 degrees.

The last one, 24 degrees makes no sense at all. I fail to see how its even possible to respond with three temperature values.

So, it seem there are some very weird things (still) going on around the thermostat and temperature… Strange enough, this is also the issue I have filed about using the Google Nest Hub. I dont use temperature or thermostat changes alot, which may be the reason why I havn´t noticed this untill I did these tests today.

So I just got a feedback from user who switched to my fork from official implementation, and he is not longer having issues with light switches. So … probably not google’s fault.

Good you mention that.

But I have to admit, I´m still not convinced, since I havn´t got a problem with switches or lights.
I also noticed, the problem I´m facing with the temperature/thermostat as mentioned above, isn´t quite the same, as I dont get the same respond when it “fails”.
But I admit, it´s highly strange and very worrying maintainer(s) seems to be vanished. If it didn´t involved lots of changes and time spending, I would give your solution a try for sure. But I simply havn´t got the time and patient to deal with it… :frowning:

There is a big PR https://github.com/openhab/openhab-google-assistant/pull/118 which will probably fix things, so no one has vanished :slight_smile:

You´re right, (I didnt follow the github for long, due to missing actions). It´s great to see the developing continues. And it sure looks like there quite some news coming. Great news!

My Google assistant started working correctly today. All ON and OFF commands work and give the correct response. I haven’t done anything new other than update some group names in my .items files which was nothing to do with Google assistant, just openHAB groupings.

nice to hear that,i still have that very annoying problem and its now worst.I get “Sorry i cant reach X right now please try again” even at the “OFF” commands.I avoid using google assistant for this…

Just said “Hey Google, turn on my living room table lamp”, the lamp is on, and my Google mini chimes. I can confirm that my Google home is back to perfect condition . The issue of “Sorry I can’t reach…” disappeared.

@MARZIMA I guess you published the promised fixes and improvements, right?