[Duplicate] Google Assistant lies to me

Tags: #<Tag:0x00007f74551c5298>

Hello,
I want to use my Google Home to operate items from openHAB.
I managed to link Google to myopenHAB cloud and when I say a command (custom routine) that does “turn XY on/off” behind the scenes, I do have the item changed accordingly BUT my Assistant apologizes that XY was unreachable.
Given I was not able to find a topic about this, I must be the only one who has this happening to me. Help! Google is lying to me! :slight_smile:

2 Likes

So are you, because you didn’t search properly! :slight_smile: (Just joking)




2 Likes

I would defend myself if you haven’t found a topic in almost every category there is. Shame on me :blush: :smile:

1 Like

I have had a working environment for several months. It seems something has changed over the weekend. We returned from a trip and we are now receiving this error. I do not use Google Assistant routines.

openHAB 2.5.0~S1687-1 (Build #1687) running on RPi 3B (Raspbian Stretch)
No changes from when we left to when the problem began to occur.

Has anybody started experiencing this issue recently?

Mike

No I haven’t, if fact I don’t even own a Google home device. But I want to thank you for digging up this old thread because Rolf’s answer to Jan’s question and Jan’s lighthearted reply made me laugh

Yes, same here, everything works, but Google says “Can’t reach xxxx” on turn on command, off and % work fine, no changes on my side.

Same here, it complains about something not working while simultaneously doing what I ask it…

1 Like

My guess is, Google is fooling around (again).
I dont use rutines and didnt notice any problem this morning when I asked Google to start the Vacuum cleaner before I left the house. But I see several others all around complaining their Google Home devices are behaving strange.
Maybe Google is getting ready for their event today :slight_smile:

Thank you! i thought i was going mad! i am seeing the same thing here at home. I am not using routines either. Commands to turn EDIT ON give me “i can’t reach XXX right now, please try again”, while commands to turn off go as expected. I first assumed that i had done something wrong as i am relatively new at this, or that it was due to a new nest hub that i installed on saturday, but i have now ruled out both over the course of the weekend.

I have gone so far as to remove all google devices at home, only use google assistant on my phone, reinstalled openhap on my Pi, only installed the cloud service, and only set up a test light as shown on this page: https://www.openhab.org/docs/ecosystem/google-assistant/ .

i still get the same behavior, turning off is fine with no errors reported, turning on i get told “i can’t reach the Test Light right now, please try again”. I guess the Question now becomes, has something happened on the cloud service side, or on the google side.

same here no routines - get sorry on turn on, but turn off works fine. No routines

Last night I tested this alot. (I normally use it quite a lot all the time, but took some extra test last night).I have no issues at all. It cant hardly be a openhab could issue, as I would assume it would reflect all of us. So my guess it, it´s Google fooling around, again.

Hey, are you still experiencing this? I am…

Me too…

ongoing issue here a well

Sometimes this happens a few times in a row, and at other times it doesn’t happen for days. Really hard to pinpoint what it could be, as communication is going back and forth through a few different services.

Same boat, similar issue is in my house setup since more than a week and it appeared after I setup routines (although not sure if it’s related). Now I changed all devices in the routines to ‘don’t change’ and removed the routines by changing my country to another country (where routines are not supported).

Also part of my troubleshooting, I tried to remove the [ “Switchable” ] tag from the .items file then re synced Google Home devices by the command “sync my devices” to remove some of the devices from Google Home and readded the switchable tag then resynced the devices with the same command, however issue still exists and again I receive the response “I can’t reach the…, please try again”, although the action takes effect successfully.

I hope someone will find a fix or any explanation to the issue.

I have another issue, which I don’t understand at all (maybe it does not belong in this thread, but given the thread name… :slight_smile: )

I have an office with two lamps, also a room that I call “work room” roughly translated, also with two lamps. Now, if I tell Google to lit the lamps in office, she lits all four lamps. Same thing with a toilet and a bathroom. Is this expected? I mean, could this be google trying to be clever with room naming, assuming toilet and bathroom are the one and same?

Hi… add me to the list of users experiencing this issue. I am getting the response "I can’t reach the ‘device name’ right now, please try again” when turning any of my devices on, although the action does indeed complete. Turning devices off gives the expected response from Google Assistant.

I believe this started at least 2 weeks ago, likely longer. I’m running OpenHab 2.4 Release… no changes/updates to it since it was installed last April.

1 Like

You are correct in your guess. Google assistant is not just a strict “if=then” but a “natural language processing” system in that if you give it a command close to one it expects it will try to figure out what you meant and fulfill your request.

The routines is a separate issue that has been going on for a while. I get around it on my third party speaker by setting a step in my routine before the lights to turn the volume to 0 then a step after the lights to turn the volume back to a soft level. I’m using one of the best buy speakers though so your results may vary.