Dyson Purelink Fan help required


Originally stumbled across this thread by @mecks52 and thought id try it

Ive been trying to get this working for the past 2 hours, unfortunately, without any luck

I ran through the steps twice, removing all files and restarting OHAB services inbetween.

Ive got device 475, and am able to run the prepare script without issues. This info then goes into my existing mqtt config file
I have mosquitto working, as I have a subscription for the sensors in my greenhouse that are reporting correctly.
The rest of the files have copied over OK, and I can see the items/sitemap in the Paper/Habmin UI respectively.

There are no errors/information in either openhab or the mosquitto logs

I tried publishing some commands with the chrome extension, MQTTLens, but cannot seem to get anything back

MQTTLens, to see if anything is going on
Im connecting it to my broker, with subscriptions:

I dont see anything on any of those coming in from the Dyson device whatsoever.

The Sitemap displays ‘NULL’ for most of its values and nothing changes on the device when I change something there

The Dyson Link App is working as it should, and the device itself responds to it as per normal

Im at a bit of a loss, can anyone able to point me in the right direction?
I can provide logs, but since theres nothing in there relating to this, I didnt bother initially.

If this works, I can also test a device 455 (Japanese model though) and a Robot Eye 360 vacuum if theres interest in getting that integrated?



let’s try it step by step.
Is the 475 reachable by the openhab server pc and the PC MQTT Lens is running at?

ping -c 4 <ip-address of 475>


Thanks for the reply
Yes, I can see the device on the network from my desktop and from openHAB, ive given it a static IP as assigned by MAC in my router.

I started again, and I can see this in the logs now
I rebooted the openhab/mqtt server, and verified that my other sensors were reporting to their broker, which they are
I then see this in the openhab logs…

2018-06-03 21:16:23.832 [INFO ] [t.mqtt.internal.MqttBrokerConnection] - Starting MQTT broker connection 'dyson475'
2018-06-03 21:16:26.970 [INFO ] [t.mqtt.internal.MqttBrokerConnection] - Starting MQTT broker connection 'localbroker'
2018-06-03 21:16:30.002 [WARN ] [t.mqtt.internal.MqttBrokerConnection] - Broker connection not started. Cannot publish message to topic '475/UM6-XG-JJA0247A/command'

Ignore ‘localbroker’ that is for other sensors
I am aware that the ‘command’ is sent periodically to update openHAB with all the dysons sensor information.

followed by this

2018-06-03 22:01:46.382 [INFO ] [penhab.io.transport.mqtt.MqttService] - MQTT Service initialization completed.
2018-06-03 22:01:46.382 [INFO ] [t.mqtt.internal.MqttBrokerConnection] - Starting MQTT broker connection 'dyson475'
2018-06-03 22:02:46.929 [ERROR] [penhab.io.transport.mqtt.MqttService] - Error starting broker connection
org.eclipse.paho.client.mqttv3.MqttException: MqttException
	at org.eclipse.paho.client.mqttv3.internal.ExceptionHelper.createMqttException(ExceptionHelper.java:38) [218:org.openhab.io.transport.mqtt:1.12.0]
	at org.eclipse.paho.client.mqttv3.internal.ClientComms$ConnectBG.run(ClientComms.java:664) [218:org.openhab.io.transport.mqtt:1.12.0]
	at java.lang.Thread.run(Thread.java:748) [?:?]
Caused by: java.net.SocketTimeoutException: connect timed out
	at java.net.PlainSocketImpl.socketConnect(Native Method) ~[?:?]
	at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350) ~[?:?]
	at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206) ~[?:?]
	at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188) ~[?:?]
	at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) ~[?:?]
	at java.net.Socket.connect(Socket.java:589) ~[?:?]
	at org.eclipse.paho.client.mqttv3.internal.TCPNetworkModule.start(TCPNetworkModule.java:70) ~[?:?]
	at org.eclipse.paho.client.mqttv3.internal.ClientComms$ConnectBG.run(ClientComms.java:650) ~[?:?]
	... 1 more

so it would seem that for some reason, the dyson broker can not start…

any ideas?

ok, not sure if this is a red herring or not… but

in the log above, we have two,


it seems its missing the letter O out of OpenHAB.

It seems, that it can’t establish a connection.
First shots are:

  • device not reachable (you already checked)
  • correct username?
  • correct password?

You could try these by using a mqtt application (e.g. MQTTLens) and see if it can establish a connection.

I cannot get it to connect

The device still ping replies, and its definitely the correct device as a port scan reveals its open on port 1883

Ive tried the username in upper and lowercase
Ive tried without user/pass combination

but it still cant get on

the username is
ive also tried

ive tried turning off/on the device too, leaving it 10 mins between the power cycle
(fully off, ie, taking the power socket out the wall)

Ive also tried a telnet to its IP on port 1883 resulting in a ‘connect failed’ message

It just times out in all cases

Not sure what else I could try at this stage.

Thema Username is
without dyson- and -475

Doesnt work either im afraid

Im going to do a deep port scan on the network, to make sure that IS the device i need to be connecting to

1 Like

A deep scan revealed that the thing is not connected to my network 100% of the time.
This is not normal Dyson device behaviour, they should be on the WLAN whenever they have power coming from the wall… regardless of the power state of the actual device (standby, on/off, whatever)

I will do a factory reset on later and hope that it fixes it. It might also need a firmware update if sorts… Otherwise, i’ll put it down to a faulty purifier and just get the wife (she works for Dyson) to take it to work and get it switched
(its a Dyson test unit, which is a potential for its strange behavior)

In the meantime, I might try a ‘PRODUCTION’ Japanese purifier, which is a 455 and not a 475
We also have a pre-production dyson 360 eye, but that has never worked properly with the app, so probably give that a miss altogether!

Thanks for your help though mate, very much appreciated :slight_smile: