Ebus 2.0 binding does not show up in Paper UI

I’ve copied the *.kar file into the addons folder but it doesn’t appear in the paper ui.

What did I do wrong?

Did you restart OH after adding the file and where did you get the file?

What version of OH are you using and how did you install it?

Yes, I did several raspi restarts as well as OH service restart.

I downloaded the file with my windows pc from here and copied it to the raspi:

I’m running OH 2.5.1-2 and I installed it via the openhabian SD card image

In the past I did it the same way as far as I remember right on a different raspi and it worked…

Thanks for the help

You could try to uninstall the last kar file from the console. Then a restart should help.

kar:uninstall org.openhab.binding.ebus-2.5.1-<version>

I think my problem starts with my bad linux skills… :slight_smile:

Typing “kar:list” leads to the following error:
-bash: kar:list: Kommando nicht gefunden.

Do I need to install a toolto use the “kar” commands?

From what I understand kar is a kind of compressed file, right?

You must use that in the openHab console, you find more information in the manual. Not on the Linux bash

ahhh… now I understand! :slight_smile:
Followed your instructions and rebooted the machine. Still does not show up…

How do I install the binding now correctly? I guess just copy it into the addons folder is not the way to do it?

Openhab is working pretty fine and it works pretty straight forward if you only do some “basic” stuff in paper ui with pre installed add ons. But if you want more it is a bit unclear for me as I do not fully understand the whole thing :slight_smile:

Thanks for you support

When you say “addons directory” Where exactly is that? Can you do an
ls -la path_to_addons
and then show the output? That should help to see if there is a permission problem or the file was corrupted during download/copying.
How did you copy it from windows to the raspi? That may have introduced a corruption possibly.

I hope I this is what you asked me for…???

[16:50:30] openhabian@openhab:/usr/share/openhab2/addons$ ls -la
insgesamt 632
drwxrwxr-x+ 2 openhab openhab 4096 Jan 19 16:51 .
drwxrwxr-x+ 4 openhab openhab 4096 Jan 14 21:07 …
-rw-rw-r-- 1 openhabian openhabian 632318 Jan 18 13:44 org.openhab.binding.ebus-2.5.1-2.kar
-rw-r–r-- 1 openhab openhab 70 Jan 12 22:53 README
[16:51:11] openhabian@openhab:/usr/share/openhab2/addons$

I just made a networkdrive on my windows machine to the raspi an copied there…

guys… suddenly it is there. For whatever reason :slight_smile:

Thanks anyway!!!

the last time I instaled it I had various items to select under supportet things. Where are they now ?

do I understand it right that I need to run ebusd to get everything into the binding?

which version should I use?


I’m using buster so strech is the one to choose. But with or without mqtt1? Or can I use the mqtt1 version anyway?

Sorry gents for asking such rookie questions you all probably cant read anymore :slight_smile:

Fuck!!! - this thing drives me crazy.

System was very slow so I thought it might be a good idea to clear the cache. So I did…

After reboot I gor en error like this:

2020-01-19 17:54:06.824 [SCHWERWIEGEND] [org.apache.karaf.main.Main] - Could not launch framework

java.lang.RuntimeException: Error initializing storage.

at org.eclipse.osgi.internal.framework.EquinoxContainer.(EquinoxContainer.java:70)

at org.eclipse.osgi.launch.Equinox.(Equinox.java:31)

at org.eclipse.osgi.launch.EquinoxFactory.newFramework(EquinoxFactory.java:24)

at org.apache.karaf.main.Main.launch(Main.java:256)

at org.apache.karaf.main.Main.main(Main.java:178)

Caused by: java.io.FileNotFoundException: /var/lib/openhab2/cache/org.eclipse.osgi/.manager/.fileTableLock (Keine Berechtigung)

at java.io.RandomAccessFile.open0(Native Method)

at java.io.RandomAccessFile.open(RandomAccessFile.java:316)

at java.io.RandomAccessFile.(RandomAccessFile.java:243)

at org.eclipse.osgi.internal.location.Locker_JavaNio.lock(Locker_JavaNio.java:36)

at org.eclipse.osgi.storagemanager.StorageManager.lock(StorageManager.java:388)

at org.eclipse.osgi.storagemanager.StorageManager.open(StorageManager.java:701)

at org.eclipse.osgi.storage.Storage.getChildStorageManager(Storage.java:1776)

at org.eclipse.osgi.storage.Storage.getInfoInputStream(Storage.java:1793)

at org.eclipse.osgi.storage.Storage.(Storage.java:132)

at org.eclipse.osgi.storage.Storage.createStorage(Storage.java:85)

at org.eclipse.osgi.internal.framework.EquinoxContainer.(EquinoxContainer.java:68)

I solved it by typing this: “sudo chown -R openhabian:openhab /var/lib/openhab2” (whatever it does :slight_smile:

Now the ebus binding which was visible before is gone again! WHY the f***???

You can use ebusd (though there is currently a bug causing it to stop for a couple of us, or you can use the serial port connection or raw network device direct connection instead. So you don’t need ebusd. If you do use ebusd it wont matter whether it has mqtt or not I don’t think so either should work. No idea why things aren’t showing up under supported things.

[solved] Thanks everyone for trying to help me!

In the end suddenly all the ebus stuff came back in the ebus binding. Maybe due to a simple sudo uodate /sudo upgrade this morning. Cant`t tell 100% if that was the reason but the main thing is… it is there :slight_smile:

Hope I manage to get data out of my heating system!