Echo alarm sound & notification volume not working anymore

Hi,

OH3.2, echo dot gen 4, SmartHome/J Amazon Echo Control Binding version 3.2.13:

I noticed that the playAlarmSound & notification volume channel are not working anymore.
I do not see any error messages in the log files, but any change of the notification volume is not visible within the alexa app and if I set an alarm sound (e.g. ECHO:system_alerts_repetitive01), than no sound is played by my echo.

Any ideas on where to start in order to fix this issue?

Thanks in advance,
Matthias

Since when do you experience these issues? If a very short time, it could be that Amazon has issues. If it’s more than a week, they probably changed something and we’ll need to adapt the binding.

Not sure, was these channels are not frequently used. Other channels are still working as expected.

I can wait a few days and test again at the weekend if that’s only a temporary issue for sure

1 Like

It took a while that I found some time to test this again:

  1. the playAlarmSound channel is still not working and I do not see any error messages in the log files.
  2. the notificationVolume channel is working, the issue was related to the alexa app not updating the volume automatically and you need to refresh the app in order to see the change.

If something related to playAlarmSound channel would have changed on Amazon side than maybe others would also posted something; therefor I am wondering why there is no other post & no error messages in my log files… :thinking:

I just tried with 3.2.14 and ECHO:system_alerts_repetitive01 works fine for me with an Echo Dot Gen. 3.

I assume you do this from a rule? Can you show the rule?

Thanks for having a look again.

Yes I use it within a rule, but even if I use a very simple script with just

events.sendCommand('EGKucheEchoDot_SpieltAlarmSound', 'ECHO:system_alerts_repetitive01');

it’s not working.
Maybe there is a difference between Gen3 and Gen4 devices? :thinking:

And the item is of cause linked to the play alarm sound channel…

Unfortunately I don’t have a Gen.4 device, so I can’t check. I added the device, linked the playAlarmSound channel to a String item and used the console openhab:send EchoEsszimmer_AlarmSound "ECHO:system_alerts_repetitive01" and that worked. Maybe it depends on the commands send before or some other setting.