Echo Devices not updating the volume channel when changed on the device

Hi, i have multiple Echo Devices (3rd. Gen Dot, 4th. Gen Dot, Fire TV Stick, Fire TV Cube, Studio, Show 5, Show 10).
I added most of them to my openHAB. I added each volume channel as a dimmer-type. I am able to change the volume of each device. It does take a bit of time (sometimes up to 10 seconds), but it works most of the time. The state of the device’s volume NEVER forwarded to openHAB when changing the volume on the device itself (+/- buttons or Alexa-App). Some of the devices are added longer than a year.

Today i was searching something in the Amazon Echo Binding and saw, that the volume is a Write/Read Channel.

I searched for mistakes i made in the past, but were not able to find any errors in my configuration.


Dimmer Amazon_Heimkino_Wohnzimmer_Lautstaerke "Heimkino Wohnzimmer Lautstärke [%d%%]" <newvolume> {

All my volume items are configured like this, no physical device reports the state back, when changed on the device itself. Am i missing something here?

Which version?

openHAB 4.0.2 Release Build

Updated to 4.0.4. Still not working. Same with bass of a specific device. (Probably also treble and mids)

The openHAB version of the amazonechocontrol binding uses web sockets for volume updates. Amazon switched to HTTP/2 streams for push feedback.

What does that mean for me? Alexa will not forward volume and co? Or is there any workaround?

You may have a look at this post.

@J-N-K Still not working. Changed the binding to the SmartHomeJ beta version but the volume is still not updating, when changed on the echo device itself. Even restarted my openHAB server without any success…

Did you logout and back in? Or tried re-register?

Yes, nothing happened. I also added a new Thing and try to not use my old ones.

Added a Echo Show 10 Thing, still not updating by itself. But what i discovered: When i deactivate the Thing and reactivate it, it takes a few seconds and the volume updates. But only if the Thing get de/reactivated.

Now i readded my Account-Thing and the state gets reported vorrectly. BUT i cannot send volume commands to any of these items.

Changing the volume on the echo device: The volume-item changes nearly instant.
Changing the volume on the volume-item: Nothing happens of the echo device.

Had to restart the server again, now both ways work.

For anyone with the same issue:

  • Uninstall your current Amazon-Echo-Control-Binding (DO NOT delete your Things)
  • Delete ONLY your Amazon-Account-Thing
  • Change the JSON 3rd-party marketplace URL:
    – OH4.0.x:|
    – OH 4.1.0-SNAPSHOT:|
  • install the SmartHome/J Amazon Echo Control Binding (beta)
  • go to https://YOUROPENHABIP:8080/amazonechocontrol
  • log out and re-register in the right top of that site
  • Readd your Amazon-Account Thing
  • Change each echo-devices bridge to the new bridge
  • restart openHAB

This fix worked for my echo devices. Now just to check my other devices that use the Alexa skills.

This only worked for the audio control on the Echo devices. I went back to the official binding as I lost all the other features that the official binding provided.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.