Eclipse automatic build runs in endless loops

eclipse
Tags: #<Tag:0x00007f51ea5dc418>

(André Füchsel) #1

With the introduction of the new bnd build system the Eclipse IDE loops endlessly between “Building Workspace(1%) - Invoking Maven Builder (/org.openhab,core) — Executing org.openhab.core.jar:jar goal” . when automatic builds are enabled (as it is by default). I always have to switch them off which is bad when working with Eclipse. An ideas?


(Hilbrand Bouwkamp) #2

Yes I had this also. In my case the fix was to use the Oracle JDK (8 201). For some reason this seems a problem with openJDK (I’ve tried different versions, because I prefer to use the openJDK. But switched to Oracle JDK because I have no idea how to figure out what the problem is and didn’t want to spend anymore time on it)


(André Füchsel) #3

Hmm, I am using Oracle JDK 8 202. Here the problem shows up. WIll now switch from Windows to Mac to see, if the issue there happens as well.


(Flavio Costa) #4

I am using Java build 1.8.0_162-b12 on Windows and I have this same issue.

It doesn’t seem to be related to openJDK as I’m on Oracle’s. Maybe it is a Windows problem then?


(André Füchsel) #5

Looks like it’s a windows issue. It does not happen on my Mac. But it is probably an issue of the combination Windows+BND+Maven… How can we find it? I am unfortunately not very fluent in bnd setups.


(Hilbrand Bouwkamp) #6

INot specific Windows. have it on one Linux machine also with both openjdk and Oracle jdk. On another Linux machine I don’t have it with the Oracle jdk. I have to research what the difference is.


(David Graeff) #7

I build a fresh copy today with openjdk in fedora Linux. That worked without a build loop. But I remember that I had that once as well a few weeks ago.

Edit: Now that I have re-opended the workspace, I do have the re-build phenomenon again. The only solution as mentioned above is to disable auto-builds for me.

Cheers David