Eclipse IDE failed to build Core

Tags: #<Tag:0x00007f1865955f40>
  • Platform information:
    • OS: MacOS
    • Java Runtime Environment: zulu8

Hi all, I followed the instructions here https://www.openhab.org/docs/developer/ide/eclipse.html to configure my eclipse IDE. I imported all openHAB working set except for Zigbee and ZWave binding. However after it finishes building automatically, many errors come out and here is the screenshot. Notice that here I only open openhab-core and Infrasturce, and leave OH2 addons and Web UIs close.


I think the problem lies mainly in org.openhab.core.model, because it lets other bundles like boot not be built. I have tried clean and re-build, but it does not work. Could anyone help me out?

I have solved this issue. I updated all bundles. But after that there are 800 errors, most with type Java Problem, come out!!! Here is the screenshot (part of):


Can anyone help me…?

I haven’t included all of openHAB core, but I think you need to generate the model classes with openhab-distro/launch/ModelGen.launch

I tried to go deeper inside an error class, and it seems that it can not find package in eclipse.smarthome.


So what happened here?

See my previous comment. Did you run the launch file?

Sometimes it can be built successfully, however sometimes it fails. Like this time it failed:

A fatal error has been detected by the Java Runtime Environment:

SIGBUS (0xa) at pc=0x00000001046dbe92, pid=24887, tid=0x0000000000002203

JRE version: OpenJDK Runtime Environment (Zulu 8.42.0.21-CA-macosx) (8.0_232-b18) (build 1.8.0_232-b18)

Java VM: OpenJDK 64-Bit Server VM (25.232-b18 mixed mode bsd-amd64 compressed oops)

Problematic frame:

C [libzip.dylib+0x2e92] newEntry+0x154
Failed to write core dump. Core dumps have been disabled. To enable core dumping, try “ulimit -c unlimited” before starting Java again