[eclipse installer] Error conflicting dependency

ide
Tags: #<Tag:0x00007f51df6b2500>

(Guenther Schreiner) #1

Hello,

does anyone has got a well-working development environment with Eclipse release 2018-12 (or anything later than 2018-09)?

As soon as I select one of the openHAB projects (either openHAB development, oH 2 Add-ons, or oH 1 Add-ons) during the advanced installation mode, the following procedure does not finish as there is an error:

Executing bootstrap tasks
Java(TM) SE Runtime Environment 1.8.0_131-b11
Product org.eclipse.products.epp.package.java.latest.released
Workspace D:\Programs\openhab-dev-1-2-master\ws
Project com.github.openhab2.2_openhab2.master
Project com.github.openhab2.3_openhab1.master
Project com.github.openhab2.1_infra.master
...
Cannot complete the request.  Generating details.
ERROR: org.eclipse.equinox.p2.director code=10054 Cannot complete the install because of a conflicting dependency.
  at org.eclipse.oomph.util.OomphPlugin.coreException(OomphPlugin.java:280)

The same error occurs on different architectures, i.e. Window7-64bit and MacOS-10.14.2.


(Ingo Theiss) #2

Hi,

I can at least confirm that I have the same problem. But I have no glue how to solve this.

Regards
Ingo


(Mirko Kruse) #3

Hi,
I have the same problem with Eclipse 2018-12 when I try to install the openHAB projects. Eclipse installation without openHAB was successful. Any hint is appreciated :slight_smile:

Regards,
Mirko


(Mirko Kruse) #4

Hi,
there’s another topic I overlooked describing a workaround by selecting Eclipse version “Photon” in the installer. This worked for me!

https://community.openhab.org/t/conflicting-dependencies-fresh-ide-install-on-mac-mojave/60715

Regards,
Mirko


(Guenther Schreiner) #5

Mirko,

you’re right that there is a workaround -“by installing product release 2018-09, which installs smoothly, instead of 2018-12.”. But this, using the older software, is exactly what we tried to avoid.

Regards, Guenther