Eclipse resolution problem after update from git

hallo,
Using Eclipse IDE, from a working environment where everything was fine, I did from cmd line for both openhab-distro and openhab-addons:
git fetch --all, git pull
and all seems aligned with the upstream offical OH repos (Your branch is up to date with 'upstream/main'.)
Then I did
mvn clean install in openhab-distro, and
mvn clean install -pl :org.openhab.binding.mybinding in openhab-addons
and all built successfully.
Yet when from Eclipse when I hit the Resolve button I now get this error.
resolve_fail

Tried several times, with different order, but the error is still there.
Any suggestion, maybe from @wborn?
Anywere else I can look at? I would like to avoid to re-install IDE from scratch.

Sometime ago I remember having such errors. IIRC what helped was waiting for bnd to finish its background processing when opening .bnd files. But I haven’t seen these in a while. Though I’ve also updated Eclipse and the bnd plugin in the meantime which may have helped.

updated Eclipse (Version: 2021-09 (4.21.0)) and bndtools to lastest.
Same error.
This bundle resolution with Eclipse and bndtools looks quite erratic… a bit frustrating also these error messages apparenty misteroius for everyone…
Also sometimes the order of things solves the problems… bah! :disappointed: not this time…

2 Likes

Same problem on my side. Any solution?

I don’t know if it helps, but if it is some kind of bnd problem, you could also try switching the bnd version back to 5.3.0 in pom.xml.

I solved by closing Eclipse, doing a mvn clean install to openhab-addons (from the folder of the binding I am developing) and restarted Eclipse.
And now Resolve works.

1 Like

I did another mvn clean install from openhab-addons and now Resolve from Eclipse does not work anymore: same error as above and my dev environment blocked again.

Tried but does not help.

Also did this: Eclipse does not show any background task anymore, for at least 10min.
But still same Resolve error.

Which versions of both do you currently use for your dev environment?

Is anywhere I can go and check for this error?
I do not even understand if it’s an Eclipse error, a bndtools for eclipse plugin error (i have updated to 6.0.0 the plugin) or a openhab-distro / openhab-addons error.

Where should I post a issue?

As the dialog shows it is a Bnd bundle resolution issue. It tries to resolve it as it is a requirement in app.bndrun :

-runrequires: \
	bnd.identity;id='org.eclipse.equinox.metatype',\

But for unknown reasons that fails on your computer.

It works fine for me with:

  • Ubuntu 20.04.3 LTS (Focal Fossa)
  • openjdk version “11.0.13” 2021-10-19 LTS
    OpenJDK Runtime Environment Zulu11.52+13-CA (build 11.0.13+8-LTS)
    OpenJDK 64-Bit Server VM Zulu11.52+13-CA (build 11.0.13+8-LTS, mixed mode)
  • Eclipse 2021-09 (4.21.0)
    Build id: 20210910-1417
  • Bndtools m2e 6.0.0.REL-202110041835-gc077e57 bndtools.m2e.feature.feature.group Bndtools

Searching the community threads it’s clear this problem occurs often to many developers, not just me. All with no solutions, except re-install everything.
The frustrating thing is that there is apparently no reason and nobody here is able to understand what the problem is. From the following picture it seems bndtools for Eclipse is badly broken: it does not find a Run Requirement (list on the right and error message) while the same tool explicitly declare as available in the looked-up repos (list on the left).

My suggestion for @maintainers as a developer for OH since 2y now is that if Eclipse is not anymore a reliable (or maintained) dev environment for OH3, it would be much better the maintainers abandon it in favour of other envs like VScode, and do not suggest it anymore to OH developers in the dev page.
In a case like mine, from a working environment I used for 1 year, I am now on a broken env, just because I updated from upstreams openhab-addons and openhab-distro.
After 1 week and 4-5 hours spent: reading the forum, updating the repos, doing mvn clean install on repos (both successful), clearing .m2 cache, updating bndtools & maven and opening Eclipse in all possible orders, I am still stuck. This is definitely something that can cause developers to run away.

1 Like

I have used Eclipse/IntelliJ and VS Code and they all have their advantages/disadvantages. With each of them I’ve also had situations where the IDE drove me completely nuts. IMHO out of the box Eclipse still has the best OSGi tooling and support. The recommendation is there to help people choose if they expect some kind of support. Certainly in the past all maintainers developed using Eclipse. Everybody is free to choose the IDE that works for him/her, just don’t expect others who do not use it to support you with that.

I myself use Eclipse in Windiws 10 but my dev environment has a certain age, maybe one year.
I plan to update to a more recent Eclipse version in the coming weeks (once I have nothing pending).

I agree with Massimo. I myself trying to get my dev environment up and running after update and still have no clue why it is not working and nobody who has more experience as I can give me an hint where to look.

What can we do to make it a better expirience for everyone?

1 Like