Ecobee - Creating a Thing

Just installed Openhab and thought I’d try and set up my Ecobee as the first real test. I thought I’d need to create a Thing for it, but I can’t seem to. Not sure if I’m doing something wrong or if the version I’m using (binding-ecobee1 - 1.10.0.SNAPSHOT) is busted. Check out the screenshot below.

I did manage to create an item, get an API key and add it as an app to my account. So I’ve got an ecobee.items and an ecobee.sitemap.

You have to create it in your .items text file. If you go to the binding help page they give you the item configuration structure.

I’m pretty syre I’ve already configured the item configuration - that’s how I was able to connect to the api. My developer app even says I have 1 install. Just in case, here’s what I’ve done.

I configured the binding configuration through the UI. It seems to work because it’s remembering my API key, and as I mentioned, Ecobee is reporting 1 install of my app. So my ecobee.cfg file is still commented out. In fact I’ve renamed it to ecobee.cfg.unused, restarted the system and ensured that my key re-appears. So that part seems legit.

Here’s the entirety of my ecobee.items. This was pretty much copied from the docs at

DateTime lastModified "last mod [%1$tH:%1$tM:%1$tS]" { ecobee="<[my-api-key#lastModified]" }
Number actualTemperature "actual temp [%.1f °F]" { ecobee="<[my-api-key#runtime.actualTemperature]" }
Number actualHumidity "actual hum [%d %%]" { ecobee="<[my-api-key#runtime.actualHumidity]" }
String hvacMode "hvac mode [%s]"            { ecobee="=[my-api-key#settings.hvacMode]" }
String currentClimateRef "sched comf [%s]"  { ecobee="<[my-api-key#program.currentClimateRef]" }
String desiredComf "desired comf"           { ecobee="<[my-api-key#runningEvent.holdClimateRef]", autoupdate="false" }
Number desiredTemp "desired temp [%.1f °F]"
Number desiredHeat "desired heat [%.1f °F]" { ecobee="<[my-api-key#runtime.desiredHeat]" }
Number desiredCool "desired cool [%.1f °F]" { ecobee="<[my-api-key#runtime.desiredCool]" }
String desiredFan  "desired fan mode [%s]"  { ecobee="<[my-api-key#runtime.desiredFanMode]" }

So what other configuration am I missing?

Hmmm. Nothing is jumping out to me as far as typos. I’ll take a look at my configuration this weekend but it looks right.

Did you install both bindings?

I’ve only installed the Ecobee and network binding. What other binding should I install?

I downloaded the openhab mobile app and the sitemap that I created for it shows up. So things are kinda working, but I don’t understand why I don’t see it listed on the control section.

There is an actions binding as well to send commands back to Ecobee -

You won’t see a listing on the control section for 1.X bindings. 1.X bindings work with OH2 through a compatibility layer but do not have support for “Things”. If someone were to make a 2.X binding for ecobee you would not a need the ecobee.cfg file and you would be able to create a Thing for it with channels for humidity, temperature, motion etc. Then it would show up under control. That being said, PaperUI is mainly for administration and testing. If you want a full featured UI you should look at HabPanel or making a site map for the classic or basic UI. You can also make your own and use the rest API that openhab provides.