Ecobee unable to set desired temperature

items
Tags: #<Tag:0x00007fe058e23728>

(Poran) #1
  • Platform information:

    • Hardware: Raspberry Pi 3
    • OS: openhabian
    • Java Runtime Environment: Raspberry Pi 3
    • openHAB version: Latest
  • Issue of the topic: I am using ecobee 4 and i was able to successfully bind it to my openHAB and I can control the HVAC Mode via the Basic UI and set it to AUTO, HEAT, COOL, or OFF. However, when I change the Heat Temperature in the Basic UI, the changes are not reflected at my thermostat. I see the logs and it states that changes are sent, but nothing happens at my thermostat. After a few minutes, the desired heat temperature sets back to whatever was manually set at the thermostat. I am hoping someone can help me debug this issue as I was not able to find any topic on this issue in the forum. Thank you.

    • Items configuration related to the issue
      DateTime lastModified “last mod [%1$tH:%1$tM:%1$tS]” { ecobee="<[511853501223#lastModified]" }

Number actualTemperature “actual temp [%.1f °F]” { ecobee="<[511853501223#runtime.actualTemperature]" }

Number actualHumidity “actual hum [%d %%]” { ecobee="<[511853501223#runtime.actualHumidity]" }

String hvacMode “hvac mode [%s]” { ecobee="=[511853501223#settings.hvacMode]" }

String currentClimateRef “sched comf [%s]” { ecobee="<[511853501223#program.currentClimateRef]" }

String desiredComf “desired comf” { ecobee="<[511853501223#runningEvent.holdClimateRef]", autoupdate=“false” }

Number desiredTemp “desired temp [%.1f °F]”

Number desiredHeat “desired heat [%.1f °F]” { ecobee="<[511853501223#runtime.desiredHeat]" }

Number desiredCool “desired cool [%.1f °F]” { ecobee="<[511853501223#runtime.desiredCool]" }

String desiredFan “desired fan mode [%s]” { ecobee="<[511853501223#runtime.desiredFanMode]" }

  • Sitemap configuration related to the issue
    Frame label=“Thermostat” {
    Text item=lastModified
    Text item=actualTemperature
    Text item=actualHumidity
    Switch item=hvacMode label=“HVAC Mode” mappings=[heat=Heat,cool=Cool,auto=Auto,off=Off]
    Text item=currentClimateRef
    Switch item=desiredComf mappings=[sleep=Sleep,wakeup=Wake,home=Home,away=Away,smart6=Gym,resume=Resume]
    Setpoint item=desiredTemp label=“Temp [%.1f °F]” minValue=50 maxValue=80 step=1 visibility=[hvacMode==heat,hvacMode==cool]
    Setpoint item=desiredHeat label=“Heat [%.1f °F]” minValue=50 maxValue=80 step=1 visibility=[hvacMode==heat]
    Setpoint item=desiredCool label=“Cool [%.1f °F]” minValue=50 maxValue=80 step=1 visibility=[hvacMode==cool]
    Switch item=desiredFan mappings=[on=On,auto=Auto] // for rule supported in 1.9
    }

(Rich Koshak) #2

Please How to use code fences.

I don’t use this binding so can’t help with your specific problem, but code fences will make it easier for those who can.


(YF) #3

Many of these items are read only. To make the actual change, you need to use the Ecobee Action. I haven’t tried to change the temperature specifically, but I changed the profile, and it works.