Either Notifications Or Remote?

Tags: #<Tag:0x00007f616f425b58>

I do have the problem that notifications don’t show up on my iPhone when openHAB Cloud Service is in mode “remote”. They do show up online and within the corresponding menue in the app, but there is no alert.

When setting the Cloud Service to mode “notification”, they do show up correctly, but then (of course) remote access is not possible.

How do I fix this?

Hi @tosteinm,

Welcome to openHAB! I haven’t heard of an issue like this before, so let’s start by making sure everything is working between myopenhab and your iPhone. Is your phone registered in myopenhab under Devices? That’s necessary for notifications to work.

You can test notifications right in this screen by sending a message to the device.

I’m not sure how/why switching from Notifications to Remote in your Cloud Connector settings would affect this, but someone with more experience might know what’s going on.

Hi @rpwong,

The device is shown within devices list, also test messages appear on my lock screen. But when sending notifications via rules, they are only shown in the notifications section in the app.

After switching from mode „remote“ to „notification“, everything works as expected, but without remote access of course.

Maybe I should configure the cloud service via config file and not via PaperUI?

PaperUI is just doing the config-file edits for you, so I don’t think you’ll see any difference. But hey, why not try it?

My best guess is that something is caching incorrectly, so uninstalling the binding, cleaning your cache, restarting OH, and reinstalling the binding might get it working. But again, that’s just a guess–I haven’t heard of this issue before.

Okay, I tried re-installing the Binding and configuring it via file. Seems to work now.

1 Like