Electronic heating thermostat reverse engineering (Beok, Floureon, Decdeal)

Hi guys,

thanks for this thread so far. I’m looking into an wlan thermostat as well and I like the floureon design.
I really appreciate that somebody has already made this device usable with openhab :clap:

What I don’t figured out from this thread so far is, that I don’t know if the device is still communication with any external server (will it call home) or will it just communicate with openhab only.

Another slightly offtopic question to the Floureon device:
The description (on Amazon and also some other shops) says, that this device is NOT applicable for water floor heating.
Can anybody tell my why?
Who has used it already with water floor heating?
I would assume It should be possible to connect the electric actuator (in german Stellantrieb) for the water floor heating with the output of the thermostat.

Thanks in advance,

1 Like

Hi Guy’s I have a Beca Energy BAC-002-ALW Wifi AC Thermostat and followed this forum but i couldnt discover any devices. It works fine with the Beca Smart app and was guessing it would be the same as the others here. Any suggestions?

I just saw the new redesigned one a few days ago too. If you wanna help integrate it maybe you could post some details in this GitHub thread?

Hi Guys,

Great topic. I have a Floureon-Smart-Wi-Fi-Programmable-Thermostat but I could never use the APP I downloaded from Google Play which why is I was happy to see this alternative (also I would prefer not to control my thermostat via a cloud). I could never get the APP to configure; it would find my WiFi SSID but after I entered my password to start the configuration it would try to load and after about 10 seconds it gave the error “Failed to add new equipment.” So I ran through the instructions in this topic and I was able to successfully install everything. However when I ran broadlink-thermostat.py I got the following result:

broadlink discover
Connect, reason: 0

Even though I was unable to configure the APP, I followed the instructions to set FAC to 32 on my device and the WiFi icon is flashing on the unit slowly, which means that it is offline.

Does anyone have any suggestions how to fix this? Am I unable to discover the device because I have to register device with the APP first? I assume this is the problem because the device has not been passed the WiFi parameters so that it can go online. Is there any way to do this in the script? Perhaps adding the ability to add network parameters is a feature which should be added in future versions so that those who don’t wish to register with the cloud (or in my case I am unable to) won’t have this problem.

For now any help to get my device discovered would be much appreciated.

Thanks in advance,

Hi again,

One more thing I would like to add. The messages during the discovery tend to repeat, however recently I received the following:

broadlink discover
Connect, reason: 0
broadlink discover
Disconnect, reason: 1
Disconnect, reason: <paho.mqtt.client.Client object at 0x40908cf0>

Don’t know if this helps in any way to debug the problem.


Finally got the app working. For anyone interested in this device, the so-called English manual is a load of crap. Anyway, after the device was registered with the app everything went perfectly. My device can be discovered so now I can concentrate on the MQTT side of things. There is however something which is a little unusual during when the device is being discovered. This is what I get:

broadlink discover
found: 0a447034ea34
PID child 16816
Hysen heating controller
set time 19:32:52 5
Connect, reason: 0
0a447034ea34 room_temp 16.5
0a447034ea34 room_temp 16.5

I tried the discovery several times and I always get the Reconnect and Connect, reason: 0 as before, but then everything proceeds normally. From what I have seen from others with a successful discovery, those two lines don’t appear. Has anyone had anything similar? Why does it reconnect after finding the device? BTW, this reconnect always occurs at the very beginning and then sometimes reoccurs later (without Connect, reason: 0), but not frequently. Also the broadlink discover line sometimes reppear but after the room temperature is shown as before.

Hi John

I bought a hysen thermostat


But I can’t set the AP mode, i think that is necessary to do the discover? I followed all the instruction but never found devices.

broadlink discover
broadlink discover
broadlink discover

The English manual is very bad explained, and I try to contact technical support, but was impossible too.

Someone can help to put this in AP MODE?

Note: I have the thermostat working with the APP.

Thanks guys

Are you sure that you installed all required libraries?
pip install paho-mqtt
pip install broadlink
pip install json
pip install pytz

1 Like

Yes, all this dependencies are installed, I tried in a raspberry, in a Mac, always the same result, not found any device.
Maybe the problem is that my thermostat is not working as AP?


Hi, could you write how you get AP working?

Great work! I used it with Floureon and it worked perfectly.

Tried with the T12-01 but unfortunately it didn’t work. It looks like there is no port open on the device itself so it’s probably subscribed to a service. From some packet sniffing it looks like it sends JSON to AWS but I haven’t been able to find out exactly what it or the App sends.

I could get it into AP mode by just letting it sit there for about a minute.
It would then provide a wireless AP THERM###

It’s this one Floureon Thermostat

This is what a registration messages looks like

I paired it with their app first, only then tried with python broadlink.

I’m using this one.

What app were you using to connect to it?
Mine uses the WeBack app.

Thanks for that. Unfortunately it looks like mine is using a different setup.

I hope you will find a way to configure it.
If you figure it out eventually please keep us updated.

Hi all. I have installed three of these, and they’re great so far, apart from the step setting being 1.5C.

This means that I set the temperature to 21C (Auto) but on switches when it gets to 19.5C. I think it also switches off when it gets to 22.5… I’d prefer a 0.5C step

Does anyone know if it’s possible to change this setting some how?

Thanks in advance!


Can you explain how you do it?

Hi @DennisVonDerBey
Can you provide more details?
I am trying to connect to this device

IWhen starting “python2.7 broadlink-thermostat.py” in Python 2.7, I am getting the following:

broadlink discover
Reconnect Disconnect, reason: 1
Disconnect, reason: <paho.mqtt.client.Client object at 0x00000000046BABE0>
broadlink discover
Reconnect Connect, reason: 5
Disconnect, reason: 5
Disconnect, reason: <paho.mqtt.client.Client object at 0x00000000046BABE0>
broadlink discover

By the way, I am able to ping the thermostat

It tries to reconnect to your MQTT broker not your thermostat. Can you connect to the former manually?