EMBER Coordinator not recognised after reboot

Dear All,

Apologies for this very newbie question from a non-programmer but I am stuck, can’t find the answer in the doc and need help. I can’t get my EMBER Zigbee coordinator to work after a reboot - it works well after first installation, and the serial port specs in the OpenHAB coordinator config have not changed after reboot. I have read the following in the OpenHAB Zigbee binding documentation:

If the USB dongle is not recognized, it might be necessary to make the dongle’s device id known to the CP240x driver by Silicon Labs:

Where do I enter the step-by-step commands indicated in the documentation to enter the device id?? I have logged onto the OpenHAB command console via SSH and tried the commands but it does not recognise them.

Any helping soul out there??

Most grateful.
Mats Rosenberg

  • Platform information:
    • Hardware: Raspberry 3 + Ember013
    • OS: Linux 5.15.32-v7+
    • Java Runtime Environment: 11.0.15
    • openHAB version:3.2.00

How did you do that ?
Did you login to the linux shell or did you login to the karaf console ( which is not correct ) ?

maybe the nrjavaserial bug? read more here

Thank you - indeed I was in the karaf console which was wrong. After a bit of testing around with various passwords and realizing that the Linux shell is accessible through port :22 I managed to run the commands but also an update of my system which fixed the problem! Many thanks for the help!

1 Like

Thank you! This was fixed in the 3.3 version so an update to my system took care of the problem. Thank you for pointing me to the solution!

1 Like

Have you restarted to test if it works?


1 Like

I shouted too early. After the second and third restart it did not work again…Now I tried to follow the instructions in the documentation to set the address of the coordinator, using the following commands:

sudo -s
modprobe cp210x
echo la86 7523 > /sys/bus/usb-serial/drivers/cp210x/new_id

The last command is not accepted with the error message

bash: echo: write error: Invalid argument

I really don’t know what I am doing and don’t want to mess things up by trial and error…I see that in the documentation text there is a reference to the CP240x, but the command says CP210x, could this be the problem. Another hypothesis, I have entered all spaces in the command as I see them in the manual, could this be wrong. And, the coordinator address shows up as la86:7523 but the syntax in the command in the documentation is la86 7523.

Any kind help in advising me what to do next??

Many thanks!