EMBER Zigbee Coordinator not restarting - Possible OpenHAB documentation error?

I’m struggling setting up an Ember USB ELU013 Zigbee Coordinator, facing the problem that it is not identified when I restart the Raspberry. I have tried following the steps below indicated in the OpenHAB Ember Coordinator installation documentation

sudo -s
modprobe cp210x
echo la86 7523 > /sys/bus/usb-serial/drivers/cp210x/new_id

The last command is not accepted with the error message

bash: echo: write error: Invalid argument

I really don’t know what I am doing and don’t want to mess things up by trial and error…I see that in the documentation text there is a reference to the CP240x, but the command says CP210x, could this be the problem. Another hypothesis, I have entered all spaces in the command as I see them in the manual, could this be wrong. And, the coordinator address shows up as la86:7523 but the syntax in the command in the documentation is la86 7523.

Any kind help in advising me what to do next??

Many thanks!

  • Platform information:
    • Hardware: Raspberry 3
    • OS: OpenHabian 3.3
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version: 3.3

is correct. There is only a cp210x firmware module in the linux stack.
You may try if it works to execute:

echo -n la86 7523 > /sys/bus/usb-serial/drivers/cp210x/new_id

Is there any output when you do

cat /sys/bus/usb-serial/drivers/cp210x/new_id

afterwards ?

Hello - @Wolfgang_S thanks for answering! No, I seem to get the same error message about invalid argument and the last command you shared does not produce any output. See full record below. Any idea?
Many thanks for your help, much appreciated,

openhabian@openhabian:~ $ lsusb
Bus 001 Device 004: ID 1a86:7523 QinHeng Electronics CH340 serial converter
Bus 001 Device 003: ID 0424:ec00 Microchip Technology, Inc. (formerly SMSC) SMSC 9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Microchip Technology, Inc. (formerly SMSC) SMC9 514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
openhabian@openhabian:~ $ sudo -s
[sudo] password for openhabian:
Sorry, try again.
[sudo] password for openhabian:
[07:04:01] root@openhabian:/home/openhabian# modprobe cp210x
[07:04:17] root@openhabian:/home/openhabian# echo -n la86 7523 > /sys/bus/usb-serial/drivers/cp210x/new_id
bash: echo: write error: Invalid argument
[07:06:06] root@openhabian:/home/openhabian# cat /sys/bus/usb-serial/drivers/cp210x/new_id
[07:07:15] root@openhabian:/home/openhabian#

I have identified the reason for the invalid argument a 1 was replaced by an l, but I can still not get the binding to work.
After entering the EMBER dongle ID

echo 1a86 7523 > /sys/bus/usb-serial/drivers/cp210x/new_id

I checked that it was created with

cat /sys/bus/usb-serial/drivers/cp210x/new_id

I then plugged in the EMBER dongle, and tried to create the EMBER binding in OpenHAB. Still no luck.

I then rebooted the Raspberry, and checked again with the cat command whether the new_id entry was there, it was not. The boot process apparently removed it or processed it somehow. I then tried again to create the binding, but still no luck.

I am completely out of ideas, and would really appreciate if somebody wiser could lend me some help.

Many thanks,
Mats Rosenberg

could you redo the above … after doing the cat command plug in the dongle; then doing sudo dmesg what is being shown there ? You should see something that describes that a device was added. What device name ( /dev/… ) is it ?

Here is what dmesg delivered, @Wolfgang_S :

[ 362.950936] usb 1-1.2: USB disconnect, device number 4
[ 362.951894] ch341-uart ttyUSB0: ch341-uart converter now disconnected from ttyUSB0
[ 362.952036] ch341 1-1.2:1.0: device disconnected
[ 595.726353] usbcore: registered new interface driver cp210x
[ 595.726450] usbserial: USB Serial support registered for cp210x
[ 717.296824] usb 1-1.2: new full-speed USB device number 5 using dwc_otg
[ 717.430020] usb 1-1.2: New USB device found, idVendor=1a86, idProduct=7523, bcdDevice= 2.64
[ 717.430065] usb 1-1.2: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[ 717.430085] usb 1-1.2: Product: USB Serial
[ 717.433962] ch341 1-1.2:1.0: ch341-uart converter detected
[ 717.437694] usb 1-1.2: ch341-uart converter now attached to ttyUSB0

Seems OK, but when I then reinitialize the binding, I still get the communications error.
And, what seems odd is that I have tried adding the new_id this way a few times. Sometimes it works and the binding works but then after 2-3 reboots it is down again. Any ideas?