Enable to install Mosquitto through the openHABian configuration tool

  • Platform information: openhabian
    • Hardware: Raspberry pi 3
    • OS: Raspbian GNU/Linux 10 (buster)
    • Java Runtime Environment: openjdk 1.8.0
    • openHAB version: OH2

Hello everyone,
I don’t manage to install Mosquitto through the openhabian config tool, when I try do install it, here is what its displayed :
And I have the same error message when I try to install other things like the Log Viewer.

Do you have an idea of what to do ?

I’d follow the message and read the openhabian-DEBuG.md file for further instructions on how to debug and either solve the issue or file an issue to get something that’s broken fixed.

Seen this often, usually it was caused by apt hanging with some unfinished other installations.
From the console try to run apt–get update or try to install something with it.
Apt may complain and give you a hint in the error message what you have to run to get this fixed.
After that openhabian–config was able to install again.

Sorry for the delay, I was on hollidays… BUT I tried apt–get update which didn’t worked and I find the issue (which was a DNS issue, I changed it to and now everything is ok !! apt–get update works well and I can download everything through the openhabian config so THANK YOU SO MUCH !!