Endpoint problem Fibaro FGS222 Double Switch

  • Platform information:
    • Hardware: AMD Turion™ II Neo N54L Dual-Core Processor, 16GB RAM SSD hard drive
    • OS: Ubuntu 18.04 LTS
    • Java Runtime Environment: Openjdk 1.8.202
    • openHAB version: 2.4.0, repository Stable
    • Aeotec gen5 z-wave usb controller

Current installation of openhab is 2.4, set up about a week ago, all my old items, rules and such put in place. I used to have a Zwave.me usb controller, but changed to a aeotec gen5 controller when making a fresh install.

I have a problem with my Popp wall controller and Fibaro FGS222 double switch.

I’m adding an association in Habmin, to the Popp wall controller so it controls “Node XX:endpoint 1”, save it, and one of the relays in the Fibaro Double Switch responds just fine.

But when i’m doing the same thing for “Node XX:endpoint 2”, the same relay that was triggered with “endpoint 1” is being triggered.

I guess the problem has something to do with endpoints:
When I look at the zwave database at Chris Jackson’s website, I can see that Fibaro Double Switch has endpoints 0, 1 and 2, but in Habmin all I see is endpoint 1 and 2. Does the endpoint 0 perhaps have something to do with this problem? Could the solution be about being able to send to endpoint 0 some how?

I’ve tried reading up on the theory behind endpoints but i’m still a novice in this matter. any help would be greatly appreciated!

@chris , any thoughts on my problem here?

You can’t. Group 1 is for switch 1, group 2 is for switch 2.

I don’t understand what you mean?

The fibari double switch is just that, two switches/relays in one product. And endpoint 1 is one of the relays and endpoint 2 is the other relay.

I’ve got it set up like this in Openhab:

Switch Stakflakt                        "(S) Takfläkt"          (Sovrum, Allalampor, ALLAlamporonoff, gDashboard)           {channel="zwave:device:9a59f25e:node27:switch_binary"}
Switch Staklampor                       "(S) Taklampor"                 (Sovrum, Allalampor, ALLAlamporonoff, gDashboard)   {channel="zwave:device:9a59f25e:node27:switch_binary2"}

…and I can control both endpoints just fine.

But when using Habmin and tries to configure my wall controller like this:

…node 27(endpoint 1) works, but node 27(endpoint2) controls the same relay as endpoint 1 does.

Nodes 22, 23 and 24 works. (and after my fresh install of openhab as described here node 25(endpoint 1) doesn’t work either, it is a fibaro dimmer 2).

Just below the part you took a screenshot of is a list over endpoints, and the enpoints are counted 0, 1 and 2. And in Habmin it is endpoints that are associated from one unit to another? And the endpoints on the Fibaro Double Switch is 0, 1 and 2, even though the association groups are 1, 2 and 3. Could that have anything to do with this strange behaviour?

Sorry, no idea. I don’t use direct associations but recently in another thread had to test it with a FGS222 and it worked fine. As I don’t have a wall controller I am not of any help here.