EnOcean 2: FGW14-USB supported

I just setup openhab in my raspberry pi 3. I have enocean 2.5.1. Can you give me more detail how I can setup fgw14 on the openhab? ( connect TX, rx and ground from fgw to ftdi usb. Also fgw14 is set in position 5)

Hi @Theofylaktos_Pieri,

I am sorry to disappoint you, but my PR to support FGW14/FAM14 per USB is still pending. I will ping it tomorrow.

Best regards

Ok Thank you for your reply!! i will wait your Update for FAM/FGW.

HI @Theofylaktos_Pieri,

good news the PR for FAM/FGW support (ESP2) got finally merged into the official binding and is already contained in the 2.5.2 snapshot.

Best regards

Hi @fruggy83

im new to openhab and i have waited longingly for the support of the fgw14-usb.
I’ve installed the latest 2.5.1 openhab but i couldn’t find a way to get the lastest snapshot of the enocean binding. Is there some kind of guide how to obtain it and how to configure the fgw14-usb?

i can hardly wait to finally test openhab (because i want to get away from fhem)

many thanks!

Never used openhab before so here’s for other guys like me how to get it to run with FGW14-USB:

The FGW-15-USB must be in Mode “6”

uninstall “old” enocean binding (check faq

get this file:
[https://ci.openhab.org/job/openHAB-Distribution/lastSuccessfulBuild/artifact/distributions/openhab-addons/target/openhab-addons-2.5.2-SNAPSHOT.kar](http://Latest Snaphot for Bindings)

extract the file: org.openhab.binding.enocean-2.5.2-SNAPSHOT.jar

copy the file to: /usr/share/openhab2/addons (if using Raspberry/Linux)

after that you sould get an error
“Unresolved requirement: Import-Package: org.eclipse.smarthome.config.discovery.usbserial”

connect via SSH and open the “openhab-cli console”
type “feature:install openhab-transport-serial”

now the binding should work

use paperUI do add the FGW14-USB

path should be “/dev/ttyUSB0”, activate the rs485 flag and choose ESP2

have fun!

1 Like

Hi @fruggy83

i got my setup running now, but unfortunately i can’t discover any devices except simple push buttons (connected via FTS14EM). every thing else isn’t recognized (tried ftks, fwg14 (similar to FWS61),…).

Can you give me a hint how to debug this?


Hi Wuehli @Wuehli,

EnOcean knows many ways to pair(/discover) a device with a gateway. For Eltako actuators you have to do a teachin to be able to controll these from openhab. Following these steps:

  • Add your device manually, choose right thing type, sending and receiving EEP and most important the right EnOceanId
  • Choose a unique SenderId or let openhab choose one for your (keep param empty)
  • Link the teachin channel to a switch item, you find this channel under “Show more” (right side of Channels)
  • Set your EnOcean actuator (more accurate the channel of your actuator) which you want to control into the teachin mode
  • Switch you teachin item to on
    Afterwards you should be able to control your actuator and receive status updates. I would recommend to start with your lights/FSR14 first.

Best regards

Hi @fruggy83,

I did a long testing with FGW14 communication. I very happy for your job and i will like to thank you!! Also i made 2 project with that. One of the project have 2 separate Panels (2 * FAM14 and 2 * FGW14) and running perfect!!

I have the same issue here! Wen connecting to fam14 directly I have no problem controlling fud14 dimmers but via the fgw14 this is not working.
Is there any benefit of a fgw over a direct fam14 connection? Improved feedback/stability?

@fruggy83 Thanks for the plugin, I also have been able to connect to my FGW14 via USB.
Although I have an issue getting feedback from my FSB14s. Controlling them works fine. Any hints?

I have a similar issue: I don’t get any feedback from my FSR14:
Although I can switch all my lights using the binding and Openhab I unfortunately don’t get the status from the FSRs if the lights are switched from outside (wall switch).

Following config I’am using:
FAM14 (Pos. 5) <-> USB <-> RASPI4

Setting in Openhab Paper UI for the FSR14 (example):

The OG-E2-1 is linked to a switch

Any hint how to read the status of the FSRs and get the Openhab Switch updated?

If the wall switch is used following log comes in:
2020-05-24 13:48:41.479 [DEBUG] [nternal.messages.ESP2PacketConverter] - Received ESP2 radio telegram: 0B0530000000FEF434AE30
2020-05-24 13:48:41.480 [DEBUG] [ernal.transceiver.EnOceanTransceiver] - Converted to: RADIO_ERP1 with RORG RPS for FEF434AE
2020-05-24 13:48:41.750 [DEBUG] [nternal.messages.ESP2PacketConverter] - Received ESP2 radio telegram: 0B0500000000FEF434AE20
2020-05-24 13:48:41.752 [DEBUG] [ernal.transceiver.EnOceanTransceiver] - Converted to: RADIO_ERP1 with RORG RPS for FEF434AE

I change FAM Pos. 5 to Pos. 4 and now a long meassage list comes from FAM14, but still no update of the switch,

Try if position 2 on the FAM14 makes a difference.

Hi Markus,
with position 2 the message looks the same as with Pos. 5 and the switch in Openhab does not change to a new status:

Hmm, I have my FAM14 set to position 2, but I am using an Enocean-Receiver not USB connecting to my Pi.
Based on the logs you posted the ACK-messages are not seen by OpenHAB, just the radio-messages from the switches.
Not sure how to debug from here, perhaps @fruggy83 can give a hint on what to try next.

Hi @damator Daniel,

If you connect your pi with the FAM14 you are directly connected with the RS485 Bus. The devices on the bus are not identified by their EnOceanId. They just use their Bus Id. So instead of the EnOceanId FFAEEC00 you have to use an Id like I guess 00000014.

Best regards

HI @timtatam Timo,

how did you configured your FSB14 in openhab? As I stated before, you have to use the BusId instead of the EnOceanId for your devices if you directly connect to your FAM.

BusId = EnOceanId - BaseId of your FAM14 (calculated in hex values) as a FAM14 just supports 128 controllable devices on the bus you can just use the last byte of the Ids :slight_smile:

Best regards

thanks fruggy for the hint.
In the thing configuration I changed the EnoceanID from FFAEEC00 to 0000014.

The ESP packet payload is now forwarded to the EnOceanBaseThingHandler but the switch is not updated. (tested in FAM mode 2 and 4).

After that is working I can also support in writing a short tutorial about the configuration with FAM14 and FSR14 by direct USB connection.

Great! This was the trick, now it works for me.

Athough I have now a follow up question: how do I get the angles of my blinds?

I configured the following:

Thing enocean:rollershutter:ogBedroomBlindsSlide "Blinds" (enocean:bridge:b1935554) [
    ] {
            Type rollershutter : rollershutter [shutTime=25]
            Type angle : angle []


Rollershutter Shutter_OG_Bedroom_SlidingDoorWindow "Bedroom Sliding Door NEW [%d%%]" <blinds> (OG, gShutterBlinds, OG_Bedroom) { channel="enocean:rollershutter:ogBedroomBlindsSlide:rollershutter", autoupdate="false"}
Number Shutter_OG_Bedroom_SlidingDoorWindowAngle "Bedroom Sliding Door Angle [%d]" <blinds> (OG, gShutterBlinds, OG_Bedroom) { channel="enocean:rollershutter:ogBedroomBlindsSlide:angle", autoupdate="false"}

somehow it doesnt display anything in the GUI. Any ideas?

Hi @fruggy83 Daniel,

I have some difficulties connecting via de FGW-14. The base ID of my FAM14 is FFF87600, the dimmer I would like to connect with has address 2. I set the address of the gateway to 00000000 and the address of the FUD14 to 00000002. In the dimmer configured 00000002 as GFVS. When I connect via the USB of the FAM14 everything seems to work but when I use the FGW-14 the dimmer is not responding. When I use the wall switches the dimmer is updated in OH. I tried a lot of combination to get it working but I’m completely stuck… can you (or someone else) give me some advise? Many thanks!!!