Enocean dimmer/roller shutter no longer work after update to 3.4


I have an Enocean based system from Eltako in my house. Basically it works perfectly.
The following Eltako actuators have been in use for almost 10 years:

  • FSR14-4 for lights
  • FUD14 for dimmers
  • FSB14 for roller shutters
    After running the whole thing on the FHEM platform for almost 9 years, I decided 6 months ago to switch to a modern platform. Since then I have been using openHAB 3.3. With a little reading I have managed everything as desired by me. I was satisfied all around.

Now I have updated today to openHAB 3.4. The update itself worked flawlessly. All bindings still look “normal”.
However, my dimmers and rollershutter are “switches” since then.
The “Thing” is still a “Rollershutter Actuator” and everything is configured as always. But under “Channels” the linked items now have a switch icon instead of a dimmer or up/stop/down buttons like before. The “Type” is still “Dimmer” or “Rollershutter”. But it still only shows the on/off switch like lights. Of course the dimmers and switches don’t work like this.
The normal lights continued to work after the update…

And sorry for expressing something unhelpful here.
Does anyone have any idea?
Does anyone here use the Enocean binding with openHAB 3.4?

Many greetings

I use enocean (Eltako devices) and openhab 3.4 without any issues. But I don’t use the openhab binding, instead I use the openocean binding. Maybe this will work for you, too.

Just uninstall your binding and install the openocean binding.
The latest compiled version is here:

Unfortunately it looks like the bindings developer @fruggy83 isn’t active anymore. So maybe we have to look for another solution for the future. I don’t think that there will be any huge fixes or updates for the binding :tired_face: :sneezing_face: :sleepy:



do you know, If there are major differences between OpenOcean and the “normal” Enocean Binding?

I don’t think so… Afaik the v3.2 has a more advanced RockerSwitch implementation.

The only change in the enocean binding in 3.4 is:

I can build a jar without this change if you would like to test it.

Rereading and trying to decode, it looks like more a UI “problem”. Is it when using MainUI?
It could be interesting to show us how is defined your utem.
What is the concerned channel?

Sorry for the late reply. Over the holidays it was very busy with me…

I think you are right with your UI assumption!
I had restored my old openHAB 3.3.0 image a few days ago. When it was reloaded I had the same problem with the 3.3.0 version too! All shutters and dimmers were just switches.
At the same time it is not possible to open the menu item “Help & About” on the left side of the menu. Then only an empty page is displayed. On the openHAB app on the iPhone I had the same problem.
At some point it worked again on the website. But I don’t remember exactly what I did… “Help & About” also worked again.
On the iPhone app it then also worked again a day later after I deleted all possible caches in the app… After the 10th try, it sometime worked again on the iPhone app too.

So currently everything works again on openHAB 3.3.0. However, I will try it again the next few days to update to 3.4.0, because I absolutely need the Shelly Plus support.

Do you have any idea how I can somehow reset the UI in case the problem reoccurs after the update?