Enocean ser2net qnap container

Tags: #<Tag:0x00007f3880cfe7d8> #<Tag:0x00007f3880cfe670>

Hi everyone,
as you can see I am a beginner and stuck, sorry.

I have enoceanpi running on a Pi3 with the TCM310 with ser2net. It all works fine on that part and I have double checked that you get something through the port with enocean devices when connection to it via telnet.

openhab:2.4.0-amd64-debian ist running within an container on my qnap. Now I want to get the enocean signals via rfc:2217 add into the path within paperui. This is where I do not get further. I get “OFFLINE - CONFIGURATION_ERROR Port could not be initialized” when configuring the enocean gateway within paper ui. The logs do not help me either

(CONFIGURATION_PENDING): opening serial port…

2019-06-06 23:12:09.342 [hingStatusInfoChangedEvent] - ‘enocean:bridge:303741d7’ changed from OFFLINE (CONFIGURATION_PENDING): opening serial port… to OFFLINE (CONFIGURATION_ERROR): Port could not be initialized

Is there anything specific that needs to be in enocean.cfg set regarding the tcp connection to enoceanpi

Help is very much appreciated :wink:

@fruggy83 maybe you can help here

Hi Kaartinen,

sorry I changed the API for the serial connections just minutes before release of 2.4. So I could not test it really good. 2.4 has a bug in rfc2217 connection. It would be the best to update to 2.5. At least M1 should contain the fix.

Best regards
Daniel

First of all thank you very much ! This did the trick and I got further with M1.
Saying that I got further. For this setup, I am running with several FAM14 with the corresponding actuators next to each other. I have the pi not connected to the FAM14 with USB directly. would that work too ? I am a bit confused with all these postings about a FAM14 .

My setup would be: encoean pi with ser2net sending to the qnap. Now the connection to the actuators would be through the fam14 but wirelessly to the enocean pi. How would I need to configure it ? is the enocean pi then connected to a RS 485 even though that it is wirelessly ?

Sorry for that question.

Greetings

Nico

Hi Nico,

I have the pi not connected to the FAM14 with USB directly. would that work too?

I have implemented ESP2 support in the openocean binding and it seems to work very well :wink: . Currently I am syncing my openocean repo with the official one, so sooner or later this feature will be merged back. ESP2 support is neccessary for USB connection to the FAM14. ESP2 is the protocol used in older enocean products.
I tested the implementation in the exact same setup as you have.
FAM14 => (USB) => Pi Zero W => Wifi (ser2net) => openhab container on qnap. This worked very well for months without a problem.
I would have kept this setup however I also use some Nodon smart plugs which use an EEP not supported by ESP2. Therefore I switched backed to the wireless setup. So it really depends on your devices which connection to prefer.

RS485 option is just neccessary if you connect your openhab enocean bridge directly to FAM14 or to a device which forwards the USB connection with ser2net. If you do not use the USB connection you do not have to activate the RS485 option.

Best regards
Daniel

Thank you very much again. Actually I got the first part working last evening as well, therefore I am getting closer.
As you have nearly the same setup, you have a quick answer to my last step as well. Adding the fsb14, fud14, fsr14 etc. would be to either use the pct tool or go one by one to each device and make the "teach in " right ?

I used the pct tool for initial wireless setup as I have a whole lot of actuators (approx 40). Later on I used the teach in for single actutors. However be sure to use the latest version of this tool as older ones where somehow buggy.
I am not sure if you can use the pct tool if you want to connect to the FAM14 by USB as the Ids are “zero based” in this case. I do not know if the tool supports Ids like 1, 2, etc. Never tried this.

I actually want to teach in manually without pct.

@fruggy83, awesome news about ESP2! I was very tempted to write a RFC2711 server that translates to ESP2 for my FGW14-USB-RS485. In theory your ESP2 should work correctly with the FGW14 to control FUD and FSR, correct? If so I am very happy to help you to test and develop this as I don’t want to have any wireless enocean in my house.
Please point me to where I can get your implementation from and I will check what I can do with it.

Hi Karsten,

the current beta release of the openocean binding contains all the ESP2 stuff. You find a precompiled version here. If you want to dig into the code you have to look into the issue13_ESP2 branch. I am currently merging all new features from openocean back to the official binding.

Would be nice if you could test the ESP2 implementation too :+1: I just own a FAM14 so ensuring compatibility with you FGW14-USB-RS485 would be great.

By the way

a RFC2711 server that translates to ESP2

is nearly the same what I am doing. Internally I am still using the already implemented EEPs and just translate the ESP2 protocol to ESP3 and vice versa. So all A5 and RPS devices like FUD and FSR should work. I did not tested my FUD but my FSR and FSB worked as expected (incl. teach in).

Hi Daniel,

thank you very much for your support and hints with the rfc2217. I got everything running now and have been busy adding all the devices etc. I have been learning a lot !!
I did integrate the Winkhaus FM.V 14 window contacts and I can see them in the logs either with the RADIO_ERP1 with RORG _1BS or RADIO_ERP1 with RORG _4BS and obviously with all the stuff after that. But when I added them for D5-00-01 (single contact) or I tried another one for A5-14-01 (generic) I do see some values for the 4BS contact and the 1BS signal I do not see anything in PaperUI. Do you have any guess ?

Greetings

Nico

Sometimes things get solved when you write it down :wink: I got it all done . The problem is that with the automatic discovery it somehow did not work. I added the single contact with 1BS and D5-00-01 manually and the change from CLOSED to OPEN and vice versa is seen. If there is any interest to add the A5-14-01 with the 4BS I am happy to help, if I know what needs to be done. Greetings Nico

Hi Nico,

nice to hear that it works now. Can you tell me which version of the binding do you use? A5-14 is already implemented and discovery should work. The generic thing is just created in case of an unkown EEP. I will check discovery of D5-00. Thanks for the hint.

Daniel

I am running on binding-enocean - 2.5.0.M1 , I will check with A5-14 again. I do get the battery value which is nice but does not do the trick with a contact :wink:

I checked it quickly and it does not work. It is right to use the “Mechanical handle sensor for window/door handles” as this has A5-14 right ? At least I do only get the battery level each contact all other information is sent in the signal but does not result in a change between CLOSED and OPEN . Probably with the handle it does but with the door contact it does not seem to do the trick.