Enshine RGB+CCT light bulbs

I am using Enshine Zigbee RGB+CCT light bulbs (Amazon.co.uk).

I’m not really sure what RGB+CCT means - they are capable of being set to RGB colours, but can also be set as white light bulbs with varying colour temperature and brightness.

I am more familiar with RGBWW (R+G+B+WW+CW) light bulbs which have 5 separate colour channels - red, green, blue, warm white, cold white.

In the Paper UI, these bulbs present two channels: Color of type Color, and Color Temperature of type Number.

I’d like to use lights as white lights of varying temperature and brightness most of the time, while retaining the option of using coloured lights.

I am using the Deconz binding to access these bulbs. In Phoscon, I have two options - either to select the Hue, Brightness and Saturation, OR, to select Brightness and Temperature. This works fine.

However, while I can see how I can set Hue, Saturation and Brightness from OpenHAB (and I have used this successfully in my Rules), I cannot see how to set Brightness + Temperature from OpenHAB.

Ideally, I’d like to be able to program R, G, B, WW, CW channels independently, but I can’t see how to do this at all, either from Phoscon or from OpenHAB.

Alternatively, does anyone know of other RGBWW Zigbee light bulbs which are supported in OpenHAB where I can control R, G, B, WW, CW channels independently from OpenHAB rules?

Thank you.

You would be able to link a dimmer item to the color channel in order to control brightness. OH will do the rest of the work for you.

In total you would have:

  • Color item linked to color channel to control color
  • Dimmer item linked to color channel to control brightness separately
  • Dimmer item linked to color temperature channel to control color temperature independent from color

Thank you. That’s very helpful. I have done as you say, and the brightness control dimmer works perfectly. When I adjust RGB colors, the light changes colour. When I adjust the brightness control, if the light was in RGB mode, it changes to warm white and I can control the brightness of the warm white light. If the light was already in “white” mode (e.g. set in Phoscon), then the brightness dimmer appears to change the brightness but does not affect the colour temperature. However, the color temperature dimmer seems not to work - whatever I set it to, the light changes to warm white and the slider jumps to “maximum” setting. Any thoughts what I may be doing wrong? Thank you.

I’m not familiar with the deconz binding and your bulb in particular.

Maybe show your thing, channel & item confusion and post the log file, that everyone can see what’s happening (or not happening).

I think the value of the “Colour Temperature” parameter may have to be between 2700 and 6500 (i.e. expressed in Kelvin) whereas a Dimmer only has values between 0 and 100. Is there any way to add a Dimmer-like control which has a value range other than 0…100?

You can link dimmer item to a numeric channel