Error 1067

hi i’m having a little error while running the openhab. i did all the instructions from openhab websit http://docs.openhab.org/installation/windows.html. the openhab is installed but not running. showing that openhab service could not be started an error occured system error 1067 the process terminated unexpectedly. am using windows 8.1, any instructions will be helpful. thanks CaptureJAVA

After starting the .bat the message states that the service is already running g. Did you check that?

Yes the service is not running.It says openhab already installed,but not running.after the run command it says an error occured cant start

Hi, I have the same issue when I try to install openHab2 an a service on an old XP laptop. Checking the Services window the service is there but not running and I cannot start manually. Error message is the same.
(I do not attach screenshots as it is Hungarian)
Any idea how to fix it?

Hi All

I am getting the same error.

I can launch the service from a command prompt openhab2-service.exe run - this works fine.

When I launch it with the Service under services.msc, it gives me error 1067

Can someone please assist? Thank you

So I was looking everywhere for this answer. I found a missing line that I thought was kind of important in the conf text that the “starting openhab as a service” instruction page said to copy and replace all in the openHab2-wrapper.conf file.

Just add “set.default.JAVA_HOME=C:\Program Files\Java\jre1.8.0_152” or where your java will be located to the conf file.

4 Likes

Thanks to @Rsslone for the on the missing JAVA_HOME record. I’ve defined a JAVA_HOME value in the enviroment variables as described in the tutorial but it seems to have no effect on the system services.

thanks Rsslone,
this fixed my setup

works for me, thanks a lot

Worked for me too, thanks @Rsslone!

That just saved me too. The wrapper properties on mine looks like this now, note the last line I just added.

# Wrapper Properties
set.default.OPENHAB_CONF=%OPENHAB_HOME%\conf
set.default.OPENHAB_RUNTIME=%OPENHAB_HOME%\runtime
set.default.OPENHAB_USERDATA=%OPENHAB_HOME%\userdata
set.default.OPENHAB_LOGDIR=%OPENHAB_USERDATA%\logs
set.default.KARAF_HOME=%OPENHAB_RUNTIME%
set.default.KARAF_BASE=%OPENHAB_USERDATA%
set.default.KARAF_DATA=%OPENHAB_USERDATA%
set.default.KARAF_ETC=%OPENHAB_USERDATA%\etc
set.default.PATH=%PATH%;%KARAF_BASE%\lib;%KARAF_HOME%\lib
set.default.JAVA_HOME=C:\Program Files\Zulu\zulu-11
1 Like

thanks
mine worked with zulu-13