Error 404 when trying to add Discovered Z-Wave Thing

I recently upgraded to 2.4 M4 and now I can’t add a discovered thing in my Z-Wave binding that worked in the past. If I use PaperUI, I get an Error 404. If I used Habmin, it just ignores it. In either case it remains in the Inbox. I have deleted the thing from the inbox multiple times and rediscovered and the issue is the same. Any ideas what to look at?

First thing to try with stuff like this is Clear the Cache.

I cleared the cache and am still having the issue. I noticed in the logs the following error “Thing zwave:device:512:node24 unable to be approved: Duplicate channels zwave:device:512:node24:switch_binary”. The device is a “DSC11 Smart Strip” and worked under previous releases of openhab2.

Did you follow the instructions here?

There was a new error check added recently that has shown some issues with duplicated channels in the database and these need to be removed.

In the case of the DSC11, this has been done already, so I suggest to update to the latest snapshot and it should be resolved.