Error entry by HABMIN: MessageBodyWriter not found for media type=text/plain

openhab2
Tags: #<Tag:0x00007f1837d171c0>

(Kris K) #21

OK, Ill go and have a play a bit more around today with it. When you say not working, do you mean with relation to using the HabMin UI (which i dont use)?


(Chris Jackson) #22

I’m not sure. The error is not related to HABmin - it’s in the standard ESH REST interfaces. Maybe the particular API is only used by HABmin, but I’m not really sure.

You might be fine leaving it - I’m just saying that based on the error, I would expect that it’s likely to cause data loss if the interface is used somewhere, so if you leave it, just keep this in mind if you have other problems.


(Kris K) #23

Scott, did you update OH2 to fix this issue or still have it? Im reluctant to upgrade but concerned about Chris’ posts about some things may not be functioning :slight_smile:


(Scott Rushworth) #24

Yes… I use the snapshots and update about weekly.


(Kris K) #25

Interesting so I should upgrade :smiley: I’m scared my hard work getting it working will break stuff!


(Scott Rushworth) #26

I made my own script for updating, which starts with a full backup. It’s easy to roll back and stress free! I’m not sure where you saw Chris comment about some things not functioning. I find the snapshots have issues now and then, but are generally more stable than releases. And the breaking changes are easier to take in small chunks than all of them at once. :wink:


(Kris K) #27

Hi Scott, could you share your script? Ill give it a go based off what you’ve said :stuck_out_tongue: who doesnt like a challenge ha!


(Scott Rushworth) #28

Here you go. This will only work for manual installs…


(Kris K) #29

Doh! I did the apt install :slight_smile:


(Scott Rushworth) #30

I haven’t looked through them yet, but there are backup and restore scripts in /runtime/bin. These might work for you.


(Kris K) #31

Indeed, i found them, used them and just upgraded to 2.4 snapshot :slight_smile: so far so good.


(Ben) #32

did the upgrade solve the problem with the MessageBodyWriter error?


(Kris K) #33

Yes Ben it did