ERROR HTTP 500 - Sitemap default could not be found

Tags: #<Tag:0x00007fc90d79a580> #<Tag:0x00007fc90d79a4b8> #<Tag:0x00007fc90d79a350>
  • Platform information:
    • Hardware: Raspberry pi 3 B+
    • OS: Openhabian
    • Java Runtime Environment: 1.8.0_152 Zulu
    • openHAB version: (I guess if it is not the last one, then one of the lastest)
  • Issue of the topic:
    When I go to http://openhabianpi:8080 is displaying http error 500 sitemap default could not be found, exactly as in the post
    HTTP ERROR 500 - Sitemap 'default' could not be found

I guess I have openhab and openhab2 (I could say that owing to in /etc I have those folders, but not sure if that means I have both installed and also “openhab-cli”) as described in the previous post, but not 100% sure… could someone told me how to check it? Also can someone help me on telling which commands execute and what to drop please?

Thank you in advance

Have you tried restarting OH to see if that clears it up?

Look at /var/log/openhab2/openhab.log for errors.

thank you for your reply rlkoshak

I have that log in mi system, but it is not updated when trying to access the web. I have another log: “/var/log/openhab/openhab.log” with the folowing information

01:08:31.751 [DEBUG] [c.internal.ModelRepositoryImpl:64 ] - Configuration model ‘default.sitemap’ can not be found
01:08:31.755 [DEBUG] [s.internal.SitemapProviderImpl:46 ] - Sitemap default can not be found
01:08:31.779 [WARN ] [e.jetty.servlet.ServletHandler:553 ] - /openhab.app
org.openhab.ui.webapp.render.RenderException: Sitemap ‘default’ could not be found
at org.openhab.ui.webapp.internal.servlet.WebAppServlet.service(WebAppServlet.java:115) ~[na:na]
at org.eclipse.equinox.http.servlet.internal.ServletRegistration.service(ServletRegistration.java:61) ~[na:na]
at org.eclipse.equinox.http.servlet.internal.ProxyServlet.processAlias(ProxyServlet.java:128) ~[na:na]
at org.eclipse.equinox.http.servlet.internal.ProxyServlet.service(ProxyServlet.java:60) ~[na:na]
at javax.servlet.http.HttpServlet.service(HttpServlet.java:848) ~[javax.servlet_3.0.0.v201112011016.jar:na]
at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:598) ~[org.eclipse.jetty.servlet_8.1.3.v20120522.jar:8.1.3.v20120522]

ah, I forgot to add that the lines that I have put in previous reply are wroten when trying to access the web

I have done the stop on openhab and then, the web page is not found
When I do the start of openHab the same error is displayed

Anyone can help please?

You can try Clear the Cache and if that doesn’t work try creating a defauly.sitemap file in the $OH_CONF/sitemaps folder ($OH_CONF is /etc/openhab2 for apt-get and openhabian installations).

Thank you very much rlkoshak :wink:

I will try tonight (Right now at work)

hi again and thank you for your support

I have been trying several things… but not results at all…

  • when trying to clean cache:
    ** sudo openhab-cli stop
    Can’t connect to the container. The container is not running.
    ** sudo openhab-cli start
    There is a Root instance already running with name openhab and pid 13454

Also, when restarting openhab, I can see those two services:
openhab2.service openhab.service
may I have 2 openhabs intalled?

following your steps I have created at /etc/openhab2/sitemaps an empty file defauly.sitemap and if I do echo $OH_CONF nothing is displayed…

Also, I have try to find a sitemaps folders in my raspberry is this is what I have found:

/etc/openhab/configurations/sitemaps
/etc/openhab2/sitemaps
/srv/openhab2-conf/sitemaps

only the file were in /srv/openhab2-conf/sitemaps. I have added the file you mention in openhap/configurations/… but nothing seems to work… :frowning:

well… yeah :slight_smile:

How did you install OH1 & OH2?

Try:

sudo systemctl stop openhab
sudo systemctl start openhab2

and work with files in /etc/openhab2/ subdirectories and monitor logs in /var/log/openhab2/

if this goes well:

sudo systemctl disable openhab
sudo systemctl enable openhab2

and remove OH1 afterwards (backup /etc/openhab folder first)

thank you very much Angelos,

that was something I tried already, but openhab2 says:
HTTP ERROR 404
Problem accessing /openhab.app. Reason:
Not Found

which I think it is more critical error.

I have not manually installed any openhab… or at least I am 99.9% sure of that. it was an OS with it already. Could it be update and upgrade? I have seen it in several times. I think what that does is upgrade same oph instance not installing a new one right?

In case deleting OH1, all of it is in /etc/openhab?

thank you

Solved

I havr been refresing the webpage, as the url could not be http://openhabianpi:8080 owing to the error… it was displaying the error

thank you very much for your help!!

1 Like