Error in installation on Raspberry Pi

Hi guys,

I’m trying to install openHABian on my Raspberry pi, but it fails in the installation process.
Here’s a few pictures of the installation and the error it gets:
After that it reboots but nothing happens.

Hope you can help me out :slight_smile:


All I can think of is a fake SD card…

You are getting the error when the pi tries to extend the file system.
Another point proving this is when you get fail instead of OK on some of the boot messages. And often a fail on different items each boot.
Check the card for being a fake one; you may have bought say a 16GB card, which has only 2GB on it. Look for test programs. e.g. fakeFlashTest, or ChipGenius… to verify… or a Kingston, which is actually not.

Once you checked the card and it is genuine; check whether the card is compatible, as some are not. (
Next thing then to check is USB cable wire gauge and power supply sufficiency…

Hi Max,

Thank you for your answer. I will try to buy a new SD card, that is compatible on that list and let you know.

Not so fast :slight_smile:
I am more for proof first… in case you bought off eBay, it is possible you’ve got a fake one; the cheaper the more likely… too good to be true kind a thing.
Nothing is lost by downloading and using the FakeFlashTest, as it will write onto the card, filling all the GBs available and reports the result.

I went through the same pain a couple of weeks ago; two fake cards, and failing installations… plus a USB cable with wires so thin that the pi would not successfully boot. I am not kidding; I cut the cables, measured the voltage drop (down to 1.5V!!) no wonder the poor Pi would not work properly.

Now with proper cables and good SD cards; they have been up ever since.

From experience: a pi installation never failed (with Wheezy and Jessie images), if power supply, USB cable and SD card were of good quality.

1 Like

So it seems there was a problem with the SD card. Tried to test it with FakeFlashTest and it says that it only has 2gb out of 16.

I have now gotten a new SD card and the installation process goes further now, but still stops with an error… Now it’s this:

If i reboot when it gets to this, it seems like it boots fine. I get to the openHABianPi login and i’m able to login through putty with openhabian/openhabian and access openhabian-config. However i can’t get to the openHAB’s web dashboard (the ip:8080 or http://openhabianpi:8080). I just get a “This site can’t be reached. openhabianpi’s server DNS address could not be found.”

Good to hear the SD card problem is resolved :slight_smile:

The other two issues on the screenshot seemed to be linked, and seem to be an openhabian image/config/set-up problem.

As for the DNS issue, I have no idea about openHabian and what it sets up, etc.
The first thing I would do is checking with ifconfig, whether your pi has an IP address, then then connect via it to 8080.

Also, instead of screenshots, you can get the boot screen messages by typing dmesg at the console prompt in a terminal session (SSH) or login in directly… and pick (cut and paste) the lines of interest.

I am of no help to you any more, and hope someone else picks up from here.

I am sure you have seen this: openHABian hassle-free openHAB Setup – maybe there is some wisdom for you in it… it was last updated on March 17th…

Thank you for your help so far Max :slight_smile:

So after further investigation, i found out that the second SD card didn’t work either… Almost drove me crazy!
I ended up buying a Sony Micro SD 16Gb (SR16UYA) and tried the installation again. This time there wasn’t a single error and i can access the web ui as well :slight_smile:

1 Like