Error including Z-Wave device in Openhab 2.2 after hard reset on the controller via Habmin

Hi there,

I’ve been using Openhab 2.2 with Z-Wave for a couple of months now. I had a couple of z-wave devices connected (mostly Fibaro switches, dimmers and wallplugs).
Then I tried to setup a Fibaro Universal Sensor, which never worked the way I wanted it to. Long story short, I made a hard reset on my Z-Wave controller and the nightmare began :slight_smile:

I have a very big problem to reinclude my devices. Mostly I get the following errors (regardless which zwave device I try to include). I first made a hard reset and then I tried to include the first device (which has been excluded and/or resetted just before).

2018-04-04 20:49:17.741 [INFO ] [age.SerialApiGetInitDataMessageClass] - NODE 1: Node found
2018-04-04 20:49:17.745 [INFO ] [age.SerialApiGetInitDataMessageClass] - ZWave Controller using Controller API
2018-04-04 20:49:17.747 [INFO ] [age.SerialApiGetInitDataMessageClass] - ZWave Controller is Primary Controller
2018-04-04 20:49:17.750 [INFO ] [age.SerialApiGetInitDataMessageClass] - ------------Number of Nodes Found Registered to ZWave Controller------------
2018-04-04 20:49:17.752 [INFO ] [age.SerialApiGetInitDataMessageClass] - # Nodes = 1
2018-04-04 20:49:17.754 [INFO ] [age.SerialApiGetInitDataMessageClass] - ----------------------------------------------------------------------------
2018-04-04 20:50:35.683 [INFO ] [mmandclass.ZWaveSecurityCommandClass] - NODE 2: setupNetworkKey useSchemeZero=false
2018-04-04 20:50:36.108 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing 'zwave:device:c61532e6:node2' to inbox.
2018-04-04 20:50:36.127 [WARN ] [rialmessage.IdentifyNodeMessageClass] - Got IdentifyNodeMessage without request, ignoring. Last message was SendData.
2018-04-04 20:50:41.175 [INFO ] [mmandclass.ZWaveSecurityCommandClass] - NODE 2: setupNetworkKey useSchemeZero=true
2018-04-04 20:50:41.179 [INFO ] [mmandclass.ZWaveSecurityCommandClass] - NODE 2: Using Scheme0 Network Key for Key Exchange since we are in inclusion mode.
2018-04-04 20:50:41.291 [INFO ] [curityCommandClassWithInitialization] - NODE 2: Setting Network Key to real key after SECURITY_NETWORK_KEY_SET
2018-04-04 20:50:41.293 [INFO ] [mmandclass.ZWaveSecurityCommandClass] - NODE 2: setupNetworkKey useSchemeZero=false
2018-04-04 20:50:41.364 [ERROR] [] - NODE 2: SECURITY_ERROR Device message contained nonce that is unknown to us, id=69.
2018-04-04 20:50:41.432 [WARN ] [mmandclass.ZWaveSecurityCommandClass] - NODE 2: payloadQueue was empty, returning!

What does this error message mean? What do I have to do to get it back running again? In this case I tried to add a Fibaro Wall plug which worked fine until I made this first reset.

Can someone please help me?

Thanks a lot in advance!

Are you trying to include the devices securely? It seems so, but if you are on OH2.2, then the binding will not support security and you should instead use the development version.

Well… I dont know. I’m doing it the same way as always. Three clicks on the fibaro switch / wallplug to put in into inclusion mode, and then I use PaperUI to scan the the inbox for new z-wave devices. These devices / configurations worked fine before…

Try disabling security then. In the controller, set Security Inclusion Mode to not use security.

it worked!!! :slight_smile: thank you very much!!