Error On Shutdown

openHABian 3 on RPi4.

I thought this was teh correct command to shut down:

sudo /bin/systemctl stop openhab.service

But I get this error whenever I run it:

The unit file, source configuration file or drop-ins of openhab.service changed on disk. Run 'systemctl daemon-reload' to reload units.

And what does this mean? What is getting dropped as a result of this?

This is no error but only a information about a changed file.

As there is no openHABian 3 yet (see, I guess you are talking of openHAB3. But which version? There are at least two official stable versions and many Milestones, not to talk about unstable versions. All of them could be installed thru openHABian (depending on when it was installed).

The symptom (openhab.service changed) is a rather old one, afair there was something with ZRAM involved, but that’s only guessing, and the issue was solved months ago.

Everything that Udo said with one addition.

Do what it says and the warning should go away. Run sudo systemctl daemon-reload.

Sorry, yes OH3, “recommended standard version” updated within the last few weeks.

Yes I thought this was old news but it’s happening on multiple systems I manage.

rlkoshak, I guess I run that once I reboot? The message appears on shutdown.

NM, I ran it from there and it worked, thanks.