Error: resolution of uriFragment '|::' failed

Running Docker-Image

resolution of uriFragment ‘|::’ failed.
java.lang.NullPointerException: null

This is my new rule. As soon as the BOLD part is uncommented, i get this error. If i comment it out, no error.
This kind of Logic (including item and sitemap) is already in use and working.

Filename: tagesmodus.rules (i copied an existing rule, renamed and replaced content)

rule “r_Tagesmodus_1”
Item i_v_Tagesmodus changed

Number i_v_Tagesmodus
Switch i_v_Tagesmodus_Auto_Aktiv

Any guess what this could be?

This is the working one

rule “r_1OG_Wohnzimmer_Beschattung_Gesamt_1”
Item i_v_Beschattung_Wohnzimmer_Gesamt changed

Item: Number i_v_Beschattung_Wohnzimmer_Gesamt

What i forgot, maybe it helps:

The working rule was created before update to 2.5.3. I dont see any differences between the working one (created before update to 2.5.3) and the new one giving the error (created after update to 2.5.3)

I also cleared already cache and tmp

Ok Guys, this happens with every new rule or every new rule content. Only the old stuff works.

I made a clean install now - works again

Did you ever find the reason for this behaviour? I have the same error. But It just started with OpenHAB so I assume a fresh install will not really make any difference (just installed it three days ago…).

As soon as I try to "Schalter_EG.sendCommand(ON) I am getting this Nul Pointer Exception, just aas you.

Any further hints?



I couldnt find out, but after a fresh install it worked again.

In your case i anyway would give it a try, do a fresh install and maybe first do a test by just adding what you need to send this command (only one thing, only this single item and this single rule).

For me, it was important to take fresh emtpy folders and just put the files (things, items, sitemap, rules) back in.

For me a reboot (with waiting for a couple of minutes after next attempt) solved the issue-

Looks like something was not propery initialised.


you mean a complete new start with a new SD_card image?
That’s a lot of work!
I recently got this error as well, but will try with clean cache and multiple restarts first.

Same error here. Started today…everything seems to be working, but logs are flooded with this. Did anyone find a fix? Apart from reinstalling everything…

This happend to me yesterday again, but was solved with a regular restart of OH

Would anyone post the whole log line containing Error: message? It does include helpful info.