[ERROR] Socket.IO error: not authorized, using myopenhab

I am unable to get an online indication at https://myopenhab.org, or to get notifications through the openHAB iOS application, although this all worked previously.

[ERROR] [io.openhabcloud.internal.CloudClient] - Socket.IO error: not authorized
  • Clean apt install of openhab2 and openhab2-addons on top of raspbian jessie. (I say clean - I issued a apt-get purge openhab2 command followed by find / -name openhab -print (no files/directories found with that name), followed by the apt install)
  • Install openHAB Cloud Connector using paperUI
  • Go to /var/lib/openhab2/uuid and cut and paste this uuid into myopenhab under my account
  • Go to /var/lib/openhab2/openhabcloud/secret and past the secret into myopenhab under my account
  • No other bindings or any other configurations made.

As mentioned above, myopenhab worked previously with a similar configuration.

# java -version
openjdk version "1.8.0_121"
OpenJDK Runtime Environment (Zulu Embedded (build 1.8.0_121-b42)
OpenJDK Client VM (Zulu Embedded (build 25.121-b42, mixed mode, Evaluation)

Also, FWIW, openHAB iOS application used to work just fine. But now it fails with the following error:
Error - Request failed: internal server error (500)

The iOS app is configured WITHOUT any internal IP address, and with the following public address:

Possible that my account has been locked at myopenHAB? I can login on the website using a web browser.

Thoughts anyone?

Did you ever find a solution for this? I’m running into the exact same issue.


Hi Matt,
I wish I could point to a specific solution. I found, while running version 1.8 of openHAB that a reboot was often required after changing parameters. This drove me crazy in troubleshooting for a while until I figured it out. I have found that OH2.1 is much better, but if you are still running 1.x, moving to OH2 can be a pretty heavy lift.

Be sure to enter the remote URL exactly as shown in the documentation. A slash in the wrong place or semicolon instead of a colon can break things.

Good luck.

1 Like

@bgilmer Do you still get this error even while it is working?

[ERROR] [io.openhabcloud.internal.CloudClient] - Socket.IO error: not authorized

@ryanr, I upgraded to 2.1 and do not get any errors now. But I think I had a syntax error, and fixed it. I still got the error but then a reboot took care of it. I hope that helps.

Thanks @bgilmer. What I found is after initially adding the the openHAB Cloud Connector add-on through PaperUI, it will show the error Socket.IO error: not authorized in the karaf log.

This is apparently expected, as the secret and potentially also the uuid have just been generated. It attempts to connect to the default Base URL for the openHAB Cloud server at https://myopenhab.org/ but fails since we need to associate an account with the newly generated secret.

I proceeded to create an account on https://myopenhab.org/ with the secret and uuid found in these locations:

openhab/userdata/uuid (or via REST API rest/uuid)

After that we need to trigger the openHAB Cloud Connector add-on to try and reconnect to the cloud server. You can either restart openHAB manually, or in my case you can simply go to PaperUI > Configuration > Services > openHAB Cloud and click “Save” on the dialog without changing anything.

Once I did this the karaf console show a successful connection and I am able to remotely access my openHAB2 instance from the web or the mobile app.

[INFO ] [io.openhabcloud.internal.CloudClient] - Shutting down openHAB Cloud service connection
[INFO ] [io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = 73a0a571-e48a-4ccf-af64-5342020b05a0, base URL = http://localhost:8080)
[INFO ] [io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service (UUID = 73a0a571-e48a-4ccf-af64-5342020b05a0, base URL = http://localhost:8080)

(Feel free to mark this post as a solution for others who also have this issue)


I am glad you were successful. What version of openHAB are you running?

I am running the 2.1.0 release docker container.

Hi Ryan,

Any idea how to mark this as resolved?

Next to the reply button of the post with the solution should be the icon image