Error testing binding in fresh development setup

Tags: #<Tag:0x00007f61709731b8> #<Tag:0x00007f6170972da8>

Hello to all,

First time setting up the development environment with Eclipse IDE acording to https://www.openhab.org/docs/developer/. When I import a test binding to give it a run and possibly try to add some new features to test, but I get the following error:

This also happens if I import one of the addons binding an try to run it.

Could someone give me a hand on this matter?

Thank you for all your help.

Best regards.

Edit: Just as additional info, I used the skeleton script to build a test binding from scartch and same error appears.

I don’t know what is causing this. It looks like a bug (or feature?) in eclipse 2020-06, probably m2e plugin. When installing 2020-03 I don’ have this issue and it’s also possible to build with maven on the command line. I have no easy solution other than install eclipse 2020-03.

Hello @hilbrand,

Thank you very much for your answer. I installed 2020-03 and the error is gone. I ran the skeleton script to build an empty binding and add it to the demo app and everything went good.
Now when I add the initial test binding to the demo app and press resolve I have the following error that I think has to do with a dependency, right?

I have the dependency added to the feature.xml and the binding builds correctly in Eclipse IDE.

Could you please help me to sort this out.

Thanks a lot in advanced for your help.

Hello again @hilbrand,

After doing some more reading and testing I added the dependency to the demo.app pom.xml file and marked the binding and the dependency to the run requirements. After pressing resolve the magic happened :slight_smile:, everything is running smooth.

Thanks for all your help.